DIY Home Improvement, Remodeling & Repair Forum > DIY Home Improvement > Painting Forum > Troubleshooting Bathroom Painting Problems





Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 08-13-2011, 02:29 PM  
vahomes
Junior Member
 
Join Date: Aug 2011
Location: Washington, D.C., Virginia
Posts: 6
Likes Given: 2

Default Troubleshooting Bathroom Painting Problems

My question is what to do now, given current status. I've done a lot of painting in my life, but am no way an expert.
Should I wait for all to dry more and try sanding again? Must I use a full primer - essentially start over - over the first coat of semi-gloss (SG)? My challenge is I'm doing this on a visit w/ relatives and must leave in 48 hours - so what are my options. Here's the detail.

I'm using self-priming Zinsser Permawhite SG mildew resistant paint (tinted pale yellow and freshly mixed for same day) for repainting walls of a bathroom (over 5-6 year old semi-gloss or satin finish taupe gray walls). The walls were not dirty, so I did no real cleaning - just wiping and scraping in a few areas that needed it. I'd prepped the walls w/ some sanded/primed spackle over a few spots of peeling paint, but did not universally sand or rough up the walls (believing the self-priming paint would handle it).
Using new low-nap edging tool and new foam roller cover, the freshly painted walls seemed to produce lots of bumps and roller lines as I painted (which I tried to correct as I went by rolling over those spots). (I read now in forum that foam rollers do that and I actually generally did use the W fanned out pattern with cross hatching). When doing that, the roller tended to remove some of the new paint, so there were adherence issues. (BTW, I don't know if you're supposed to start on unpainted area and paint into already painted or the other way around - can anyone tell me that?). I coated the walls last night, but it was clear I'd need a second coat - maybe even third - both for color coverage and for thinness and unevenness of some of the paint.
About 8 hours after initial coating, I tried sanding off some of the bumps in the paint (that weren't previously there on the wall). Of course, I have a gummy mess in those areas, with the paint peeling off in strings. So I scraped in a couple areas with a Hyde painters tool - and there's no stopping place. Sorry to make this so long, but I'm not sure what info is essential for getting answers.
Help?!!! I'm just trying to do a favor and it's turned out to be a disaster.



__________________
vahomes is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Bathroom painting JIP Decorating and Design 14 08-13-2011 10:17 PM
GFI Troubleshooting Joshadog Electrical and Wiring 2 05-09-2011 06:42 AM
Painting The Bathroom Door Kithikor General Home Improvement Discussion 1 04-27-2011 06:23 AM
Fluorescent troubleshooting Daffypuck Electrical and Wiring 6 09-14-2009 05:31 AM
GFI Tripping and troubleshooting jwar Electrical and Wiring 4 02-08-2008 09:14 AM