DIY Home Improvement, Remodeling & Repair Forum > Appliances > General Appliance Discussion > Ceramic stove top




Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 05-08-2012, 08:43 PM  
Rich55
Junior Member
 
Join Date: May 2012
Posts: 12
Default Ceramic stove top

I was installing a new control knob for one of the elements. I wrote down the pin outs with the matching wire color. I turned on the power switch the knob of the broken element , it started to spark and it tripped the
Main 40 amp breaker. I took it part again to check for any black marks and didn't any. I put back to together how it was. It didn't blow the Main breaker .the element that was broken works but the dual element does not work. Could I have blown a breaker on the stove or shorted out the element, rendering it useless?



__________________
Rich55 is offline  
 
Reply With Quote Quick reply to this message
Old 05-09-2012, 07:03 AM  
jeff1
Contractor
 
jeff1's Avatar
 
Join Date: Mar 2006
Posts: 434
Liked 24 Times on 21 Posts
Likes Given: 1

Default

Hi,

Make, model#?
http://www.applianceaid.com/model.html Some model# helps.

Quote:
I was installing a new control knob for one of the elements
Knob or switch?

Which element where you working on and which is now not working?

jeff.


__________________

Appliance Repair Aid
http://www.applianceaid.com/

jeff1 is offline  
 
Reply With Quote Quick reply to this message
Old 05-09-2012, 01:40 PM  
Rich55
Junior Member
 
Join Date: May 2012
Posts: 12
Default

It is a kenmore. The small top burner but now the double burner does not work

__________________
Rich55 is offline  
 
Reply With Quote Quick reply to this message
Old 05-09-2012, 08:27 PM  
jeff1
Contractor
 
jeff1's Avatar
 
Join Date: Mar 2006
Posts: 434
Liked 24 Times on 21 Posts
Likes Given: 1

Default

Kenmore is made by several different companies....model#?
http://www.applianceaid.com/model.html
http://www.applianceaid.com/searscodes.html

jeff.

__________________

Appliance Repair Aid
http://www.applianceaid.com/

jeff1 is offline  
 
Reply With Quote Quick reply to this message
Old 05-11-2012, 10:45 AM  
Rich55
Junior Member
 
Join Date: May 2012
Posts: 12
Default

Model number is 1015398 from the back off the stove
Thanks
Richard

__________________
Rich55 is offline  
 
Reply With Quote Quick reply to this message
Old 05-11-2012, 07:49 PM  
jeff1
Contractor
 
jeff1's Avatar
 
Join Date: Mar 2006
Posts: 434
Liked 24 Times on 21 Posts
Likes Given: 1

Default

Model#'s are normally not on the back...they are accessible from the front...



jeff.

__________________

Appliance Repair Aid
http://www.applianceaid.com/

jeff1 is offline  
 
Reply With Quote Quick reply to this message
Old 05-21-2012, 06:20 PM  
Rich55
Junior Member
 
Join Date: May 2012
Posts: 12
Default

Hey Jeff
The model # C970 655821
Serial # NF 43212458
Thanks
Richard

__________________
Rich55 is offline  
 
Reply With Quote Quick reply to this message
Old 05-22-2012, 06:54 AM  
jeff1
Contractor
 
jeff1's Avatar
 
Join Date: Mar 2006
Posts: 434
Liked 24 Times on 21 Posts
Likes Given: 1

Default

Quote:
C970 655821
Crap, a Canadain Kenmore.....Canadian models #'s ( esp dept store brands ) are not online so we cannot look up much for them.
970. is a Frigidaire built Kenmore.

Quote:
I was installing a new control knob for one of the elements
Maybe we can try with the part# you purchased.

Quote:
Could I have blown a breaker on the stove or shorted out the element, rendering it useless?
Normally no breakers in the range ( exception is often the kettle outlet plug ). If just the switch was replaced, possible the wires got mixed up damaging the switch for the element on that same side ( left or right ).

jeff.
__________________

Appliance Repair Aid
http://www.applianceaid.com/

jeff1 is offline  
 
Reply With Quote Quick reply to this message
Old 05-22-2012, 09:02 PM  
Rich55
Junior Member
 
Join Date: May 2012
Posts: 12
Default

I match all the wires to its corresponding colours for example L1 white, P blue, H1 white with blk tape ( to distinguish between whites) H2 white L2 black. The new part # 318293810. I upload two picture of the original control swt. I don't know if this will help.
Thanks Jeff

Richard

image-186896865.jpg   image-1281463308.jpg  
__________________
Rich55 is offline  
 
Reply With Quote Quick reply to this message
Old 05-22-2012, 09:09 PM  
Rich55
Junior Member
 
Join Date: May 2012
Posts: 12
Default

Quote:
Originally Posted by jeff1

Crap, a Canadain Kenmore.....Canadian models #'s ( esp dept store brands ) are not online so we cannot look up much for them.
970. is a Frigidaire built Kenmore.

Maybe we can try with the part# you purchased.

Normally no breakers in the range ( exception is often the kettle outlet plug ). If just the switch was replaced, possible the wires got mixed up damaging the switch for the element on that same side ( left or right ).

jeff.
It's the element on the bottom right that is broken now but the element on top right is the one I fixed. It's working as it should( top right) The bottom right element red indicator light is always on but is not warm nor hot to the touch. All I can think of is its a dead short to the right element. Indicating a hot surface with no heat to the ceramic top.
Thanks
Richard


__________________
Rich55 is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Dog pee on ceramic tile... yellowkat Cleaning 16 07-18-2014 08:23 PM
Ceramic tile sawdst Flooring 2 11-20-2009 10:13 PM
Ceramic Tile kcscorpio68 Flooring 5 08-06-2009 07:49 PM
Pricing on ceramic richiek Flooring 2 11-17-2006 04:13 AM
Ceramic Tub Incloser Radioman General Home Improvement Discussion 8 09-22-2006 09:44 PM