DIY Home Improvement, Remodeling & Repair Forum > Appliances > General Appliance Discussion > Evergrind E202




Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 09-02-2014, 08:19 AM  
kkcarlton
Junior Member
 
Join Date: Sep 2014
Posts: 1
Default Evergrind E202

Hi,

I have the same problem many have mentioned here yet none of the threads I read helped me.

Evergrind E202 disposal bought and installed about 2 weeks ago. Last night I put ice down the disposal, turned it on and it jammed and started spraying stuff ground up food out of the top. I turned it off, noticed a tea bag was in the disposal and the string was wrapped around one of the blades. Removed all of it, let the disposal cool off, made the blades turn with the hex tool in both directions, made sure nothing else is in the disposal, pressed the reset button and it does not work. It makes a humming noise but will not run. The blades turn freely and easily with the hex tool.

Anything else I can try? We are renting this house and the owner lives in another state. He had a friend go buy and install this GD and I would hate to bother them after such a short time. This thing is two weeks old...really hoping it does not have to be replaced.

Thank you for any suggestions.

~k



__________________
kkcarlton is offline  
 
Reply With Quote Quick reply to this message
Old 09-02-2014, 06:30 PM  
nealtw
Contractor
 
Join Date: Nov 2010
Location: vancouver, b.c.
Posts: 10,277
Liked 850 Times on 759 Posts
Likes Given: 1466

Default

Welcome to the site. You may need to call the manufacturer.

__________________
nealtw is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On