DIY Home Improvement, Remodeling & Repair Forum > Appliances > General Appliance Discussion > GE refrigerator compressor cooling fan problem




Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-15-2009, 12:38 PM  
Clayton
Junior Member
 
Join Date: Apr 2009
Posts: 4
Default GE refrigerator compressor cooling fan problem

Model #PFS22MBSBBB Purchased 8/1/05. The compressor cooling fan stopped working and the fridge started to overheat. This happened on the friday night before Easter. We took the back panel off, set a small fan back there, the freezer temp went down, and the fridge worked fine all weekend. The Local electric company does appliance repairs and so I called them. The repair man said power was coming to the motor. He had brought a new mother board with him, but decided it could be just the motor, and so he ordered a new one. He came back today with the new motor and installed it, but when he plugged up the fridge it would not run, just made some clicking sounds, and so he quick unplugged it, and said - it's the mother board too. So he replaced that, and everything than ran as it was supposed to.

The mother board did have a burned spot on it at C32, R6 end.

I asked if he was sure the old motor was bad and he said he was sure.
All that cost me was $410.00. The day the trouble started there had been a bad electrical storm that morning. Might be related.

But I can't help but wonder if that motor was really bad? And how could I find out? He left the old parts here.



__________________
Clayton is offline  
 
Reply With Quote Quick reply to this message
Old 04-15-2009, 04:22 PM  
kok328
Supporting Member
HRT_SUPPORTER.png
 
Join Date: Nov 2007
Location: Grand Blanc, MI
Posts: 2,169
Liked 100 Times on 88 Posts
Likes Given: 61

Default

Well, if the motor is 120VAC then you can take a cord whip and wire it back up and plug it into an outlet to test it. Seems funny that power was going to the motor but, yet it wasn't working. This would tell me the motor is bad but, why a new motor required a new motherboard is beyond my understanding. Unless the old board had an intermittent sticking relay that ran the fan circuit. In this case it would have been cheaper to replace the relay but, most service techs view boards as plug and play, no in-the-field repairs. Hopefully, the appliance pros will enlighten us.



__________________

Last edited by kok328; 04-15-2009 at 04:24 PM.
kok328 is offline  
 
Reply With Quote Quick reply to this message
Old 04-15-2009, 04:32 PM  
Nestor_Kelebay
Emperor Penguin
 
Nestor_Kelebay's Avatar
 
Join Date: Mar 2009
Location: Winnipeg, Manitoba
Posts: 1,844
Liked 2 Times on 2 Posts

Default

Quote:
Originally Posted by Clayton View Post
But I can't help but wonder if that motor was really bad? And how could I find out? He left the old parts here.
Just look in your Yellow Pages phone directory under Appliances-Repairs, and phone around to find out who the factory authorized GE repair depot in your area is. If there is none and you have to phone GE directly for them to send out a service tech from their parts distributor in your area, you can just leave the motor at the parts distributor for the technician to test, or you can just take it to any place that repairs GE appliances listed in your phone book.
__________________
Nestor_Kelebay is offline  
 
Reply With Quote Quick reply to this message
Old 04-16-2009, 07:51 AM  
Quattro
Massive Tool Belt
 
Join Date: Oct 2006
Posts: 262
Default

This is fairly common with GE fridges, unfortunately. I went through the same thing several months ago. The condenser fan is actually 12VDC, so you can test it with a 9V battery. That's what I did. Mine worked fine, AND was getting voltage, just not the "turn on" signal from the motherboard. Actually, my thread is still around here somewhere...

Anyway, I ordered a new board, installed it myself, and the whole thing cost about $100. Not too bad, but still GE should do something about this problem.

Good luck!

__________________
Quattro is offline  
 
Reply With Quote Quick reply to this message
Old 04-16-2009, 07:56 AM  
Quattro
Massive Tool Belt
 
Join Date: Oct 2006
Posts: 262
Default

Here's my thread:
http://www.houserepairtalk.com/f11/ge-profile-refrigerator-condenser-fan-not-turning-4491/

__________________
Quattro is offline  
 
Reply With Quote Quick reply to this message
Old 08-17-2009, 06:31 PM  
bradee
Junior Member
 
Join Date: Aug 2009
Posts: 1
Default

this is for quattro or other gurus out there:
I too has a GE profile arctica model# PSS25SGMABS, the condenser fan motor is turning slow. I vacuumed the whole condenser & motor but it still turning slow that the compressor is over heating & sometimes shuts off on overload. Is possible that the only problem is the motor & not the board? if it is the board where is it located. All the help is highly appreciated

__________________
bradee is offline  
 
Reply With Quote Quick reply to this message
Old 08-17-2009, 08:46 PM  
woodchuck
Senior Member
 
Join Date: Jul 2008
Location: Tuscaloosa, Al
Posts: 244
Liked 16 Times on 15 Posts

Default

Part 801 on this diagram is your motherboard. GE | Model #PSS25SGMABS | REFRIGERATOR M SERIES | UNIT PARTS | SearsPartsDirect.com
Your fan is a dc so test it with 110 volts. I would tend to think the problem is just the fan. Put a floor fan back there and see how it does for a few days. Your fan is 80 dollars on the above site.

__________________
woodchuck is offline  
 
Reply With Quote Quick reply to this message
Old 08-09-2010, 08:58 AM  
amphibian
Appliance Repair Master
 
Join Date: Aug 2010
Location: Lufkin, Texas
Posts: 1
Default

As "Woodchuck" states: "Your fan is a dc so test it with 110 volts." Ya, right, get ready for the smoke test if you do. Let me know how that works for you.

Actually now, the real truth. This is not a "major" problem with the new GE's. These refrigerators are completely controlled by the main board located on the rear of this refrigerator. This main board controls temps in side both the freezer & refrigerator by means of monitoring the voltage changes on the thermistors. In addition, this main board also controls the fan speeds of the 12vdc fans in the freezer, refrigerator and the condenser fan. Yes, it is likely that the fan can be turning at a slow speed and still be bad. These fan motors are housed in a plastic housing, they don't take heat too well (like having it shuved up against the rear wall with no air circulation for long periods of time) and they don't last forever. You could have a defective fan and a defective main board at the same time. In fact, the main board dc voltage regulator on the condenser fan side can actually short out and take the condenser fan out by means of over-voltage (more than 12-15 volts dc). These fan motors will only handle so much voltage until the coils burn, but even if they burn they can still turn at a lower speed. There is a way to check them, if you don't mind paying the 1200.00 dollars for the test set. It requires having the ability to send a startup signal and a rpm current sensor to see if it is actually any good are not(the function of the main board). If your freezer temps are fluctuating between 10-30 degrees at different times of the day/week as displayed on the display panel or by means of a thermometer stuck inside the freezer and the refrigerator is maintaining proper temps, then suspect the condenser fan, and/or the thermistors inside the freezer and/or the main board. This is not a "cheap" refrigerator to purchase and not "cheap" to repair. Still, a main board and condenser fan are a lot less expensive then a new refrigerator.

__________________
amphibian is offline  
 
Reply With Quote Quick reply to this message
Old 09-17-2011, 09:03 AM  
jesselund
Junior Member
 
Join Date: Sep 2011
Location: Irvine, CA
Posts: 1
Default

I know this post is about a year old, but it sounds identical to the problem we're having with the same monogram fridge (42-in built-in - about 5 years old). We have found that the access panel at the top, if open, allows the fridge to operate normally, but when closed, especially during summer months, the freezer starts heating up and things start thawing out. Does this sound like a main board problem? A condenser fan problem? I can see the condenser fan turning when the access panel is open -- it is drawing air, but there is little ventilation on the back of the fridge (i.e. just a little space between the back of the fridge and the wall). Should we drill some ventilation holes in the drywall and above the cabinetry (still out of sight) to allow the back of the fridge to draw air from the main room?

This seems to be a common problem, but we're just trying to figure out the most cost effective approach to solve -- i.e. buy a new main board, new fan, or just modify the ventilation in the wall behind the fridge.

__________________
jesselund is offline  
 
Reply With Quote Quick reply to this message
Old 03-05-2012, 06:41 PM  
5gordons
Junior Member
 
Join Date: Mar 2012
Posts: 1
Default

Jesslund.. did you find a solution? I think I had the same problem the last two days. I also have 42" Monogram. I opened the top and the clicking stopped shortly thereafter. 24 hours later, same thing. I vacuumed-out the coils and everything up there, and the fan started to run, but that may have been a coincidence. OR MAYBE NOT, since it wasn't running before I vacuumed it, but the compressor was super hot to touch. I'm curious to see if it was cleaning that reset the fridge's sensors up there.



__________________
5gordons is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Fridge not cooling again............ Shorty Quiroga General Home Improvement Discussion 4 11-28-2012 10:41 AM
Home AC not cooling - help! TexasKid HVAC 11 07-10-2009 08:03 AM
GE Hotpoint CTX14WAYCTH Cooling..but not enough! brewski General Appliance Discussion 11 10-19-2008 08:29 AM
Refrigerator cooling dyer724 General Appliance Discussion 2 11-27-2007 09:49 PM
Hotpoint refrigerator not cooling aces11 General Appliance Discussion 24 10-17-2007 01:10 AM