DIY Home Improvement, Remodeling & Repair Forum

DIY Home Improvement, Remodeling & Repair Forum (http://www.houserepairtalk.com/forum.php)
-   General Appliance Discussion (http://www.houserepairtalk.com/f11/)
-   -   KitchenAid oven kems377dbl4 (http://www.houserepairtalk.com/f11/kitchenaid-oven-kems377dbl4-12358/)

tpkenny 10-22-2011 08:20 PM

KitchenAid oven kems377dbl4
 
I am getting no heat or juice to either element. Checked out the oven sensor and fuse on the back and they are ok. Juice going into the control panel is ok. All display lights work on the panel. No error MESSAGES. Microwave works fine. Any way to check out the control board.

joecaption 11-11-2011 06:51 PM

My guess is your only getting 110 not 220 volts. The reason I say this is the controls, lights and micowave run on 110 volts.
Use an ohm meter to to check from ground to each lead. It should say 110 volt on each side. If one shows nothing, that it.
Could be the breaker or a loose connection in the plug. 220 volts will kill you so make sure to trip the double breaker before opening up the outlet.

jeff1 11-12-2011 09:18 AM

Hi,

As mentioned...have you confirmed correct power is comming to the unit?
220-240 volts AC from black to red, 110-120 volts AC from black to white or red to white.

Quote:

Checked out the oven sensor and fuse on the back and they are ok
Sensor is more for temp and normally won't stop the oven from working....how was the thermal fuse checked?

Quote:

Juice going into the control panel is ok. Any way to check out the control board.
Power comming in, turn on oven and check for power comming out.

jeff.


All times are GMT -6. The time now is 05:50 AM.