DIY Home Improvement, Remodeling & Repair Forum > Appliances > General Appliance Discussion > No power to bake element





Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 07-11-2008, 11:29 AM  
Tazman
Junior Member
 
Join Date: Apr 2008
Location: Cameron Park, CA
Posts: 23
Default No power to bake element

Hi all

Older GE oven/micro combo. bake element fried and broke in pieces. got a new one, installed it and no heat. upper element and light and micro work. put a test lite on the two leads with oven on and no power. I am assuming I blew something in addition to the element?

Any help appreciated!
Thanks
Randy



__________________
Tazman is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Rinnai tankless water heater and a power outage rolltrain General Appliance Discussion 5 01-25-2013 06:58 PM
Power outage, tripped GFI? naraiz Electrical and Wiring 2 12-24-2008 05:53 AM
power washing kok328 General Home Improvement Discussion 2 07-06-2008 08:49 AM
2 questions - vanity light and romex with no power rando Electrical and Wiring 5 05-27-2008 06:27 AM
House looses power when using more than 1 light sorethumb Electrical and Wiring 5 07-09-2007 08:26 PM