DIY Home Improvement, Remodeling & Repair Forum

DIY Home Improvement, Remodeling & Repair Forum (http://www.houserepairtalk.com/forum.php)
-   General Appliance Discussion (http://www.houserepairtalk.com/f11/)
-   -   What's wrong with my kegerator (http://www.houserepairtalk.com/f11/whats-wrong-my-kegerator-5673/)

nberggren 12-03-2008 07:15 PM

What's wrong with my kegerator
 
I have a Haier HBF05EBSS "Beverage Dispenser" it's worked great for 3 years. I came home after Thanksgiving travel and found the kegerator was not cold at all. The compressor was hot but clearly no cooling had gone on for awhile.

I unplugged it then plugged it back in. I heard the characteristic click of the overload protector kicking in. At this point I figured I had a serious issue but started investigating the electrical components. I did some troubleshooting for compressor issues and didn't really find anything out of the norm. After I reassembled everything I plugged it back in. To my surprise it started up fine and it was cooling. I then unplugged it rolled it back to it's normal location and plugged it back in. Nothing... The overload didn't kick in but I could hear a faint humming from the compressor. So I unplugged it again waited a little while then plugged it back in started up again.

I replaced the starter relay with the exact same model relay. Same story. Starts once then doesn't seem to want to start again for awhile.

What could be going on? Is there anything else I should check?

woodchuck 12-03-2008 08:14 PM

Try what they call a hard start kit. That may give it a few more years. Do a Google search for it.

nberggren 12-13-2008 08:23 AM

follow up:

Like I originally said if I let it sit a little while then plug it in the compressor runs fine. So I did just that I plugged it in and let it do it's thing. It's been working fine since the 3rd.

Is there something built in that keeps it from cycling quickly? I was unplugging it then plugging back in less then 5-10 seconds. When it cycles on it's own it works fine.

Still doesn't explain why it didn't run for several days while I was gone.

woodchuck 12-13-2008 03:00 PM

Yes there is something that prevents another start too soon after it runs. There is too much pressure to restart immediately.

Bungalow 01-10-2009 08:45 AM

I am having the same problem. But my compessor won't start back up at all. I hear the overload click. I have unplugged it for 24 hrs and still nothing. BTW, same model and also around 3 yrs old.

glennjanie 01-10-2009 12:39 PM

Hello Nberggren:
Once a compressor builds a high head pressure, it doesn't have the power to start again soon. They usually have a 3 minute time delay to allow the pressures in the system to equalize before the compressor tries to start again.
Woodchuck is correct in saying you need a hard start capacitor. You can pick one up at Grainger or other supply stores, it has instructions with it for installation.
Glenn

Icehouse 01-10-2009 02:33 PM

What is being told is made by "Supco" Number RCO-410.Most good appliance parts stores carry them. :)

brumfan 01-13-2009 05:55 PM

The hard start kit may not work if you have a plugged or restricted cap.tube.
The pressures will not equalize when the compressor is off and it will not restart without going off on the o/load.
If the tube becomes plugged while the compressor is running, it will not cool but will continue to run. Look for any ice build up around the drier where the cap. tube enters.

SublimeMasterJW 01-25-2009 08:03 PM

If the compressor is getting hot hot then the relay may be shot and the RCO410 would be the perfect fix. Best way to tell is remove the relay on the compressor and check it.Give it a shake and see if tiny relay particles fall out. It oughta make a thunk noise (sliding start switch) no noise at all probably fried. BTW: ain't seen nothing worth a sh*t made by Haier yet.


All times are GMT -6. The time now is 10:49 AM.