DIY Home Improvement, Remodeling & Repair Forum > Appliances > Refrigerators > GE Refregarater, Freezer works but main cabin not cold!!





Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 01-06-2012, 07:15 AM  
jtwh20
Junior Member
 
Join Date: Jan 2012
Posts: 1
Default GE PFS22SISBSS not cooling after motherboard replacement

My motherboard went out (fridge not cold, display not lit, constant clicking coming from motherboard area).

I found the part number (thanks to this site) and replaced the motherboard.
Now the fridge display is lit, and it turns on, but it is not cooling, even after 24 hours.
The fans are running as I can hear and see them turn. After 24 hours the compressor was super hot and the fridge nor freezer were cold.

Any suggestions / things I can look at next?

Thanks,
Jay



__________________
jtwh20 is offline  
 
Reply With Quote Quick reply to this message
Old 01-08-2012, 07:17 PM  
jeff1
Senior Member
 
jeff1's Avatar
 
Join Date: Mar 2006
Posts: 411
Liked 17 Times on 16 Posts
Likes Given: 1

Default

Hi,

Quote:
constant clicking coming from motherboard area
Quote:
After 24 hours the compressor was super hot and the fridge nor freezer were cold.
See if the compressor is acually running. Sometimes the clicking is comming from the compressor.

jeff.


__________________

Appliance Repair Aid
http://www.applianceaid.com/
I support MADD, please don't drink and drive!

jeff1 is offline  
 
Reply With Quote Quick reply to this message
Old 01-08-2012, 09:16 PM  
woodchuck
Senior Member
 
Join Date: Jul 2008
Location: Tuscaloosa, Al
Posts: 236
Liked 14 Times on 13 Posts

Default

You said your fans are working. Make sure one of them is the the condenser fan at the back underneath near the compressor. If it's not running the compressor will get hot. The condenser coils near there should be warm. If not, the compressor is not working.

__________________
woodchuck is offline  
 
Reply With Quote Quick reply to this message
Old 05-15-2012, 06:23 AM  
RazorbladeUSMC
Junior Member
 
Join Date: May 2012
Posts: 1
Default GE Refregarater, Freezer works but main cabin not cold!!

I had a circuit board replaced about an year ago because my refrigerator stopped working, now the freezer works but my food in the main cabin does not get cold.... HELP!! I'm a Disabled US Marine and I need to keep my Med's cold and I'm on a limited income!!

__________________
RazorbladeUSMC is offline  
 
Reply With Quote Quick reply to this message
Old 05-15-2012, 10:12 AM  
woodchuck
Senior Member
 
Join Date: Jul 2008
Location: Tuscaloosa, Al
Posts: 236
Liked 14 Times on 13 Posts

Default

The fridge gets its cold air from the freezer through a vent(damper) between the freezer and fridge.The fan in the freezer blows air through it. Make sure this fan is running. You may have to hold the door switch in for it to run. There is a flap you adjust with the fridge temp. control. Make sure it's opening and closing when you adjust the fridge temp.
The problem could be the electronic control if you have one or the mechanical linkages.*

If the evaporator coils behind the back panel of the freezer are icing up because of auto defrost failure that will stop the circulation of cold air and eventually affect the freezer too.

check defrost timer, defrost heater, defrost thermostat. In most newer models the timer has been replaced by an electronic control board. If the heater and thermostat are ok it’ll be the control.

__________________
woodchuck is offline  
 
Reply With Quote Quick reply to this message
Old 05-15-2012, 02:25 PM  
jeff1
Senior Member
 
jeff1's Avatar
 
Join Date: Mar 2006
Posts: 411
Liked 17 Times on 16 Posts
Likes Given: 1

Default

Hi,

Quote:
now the freezer works but my food in the main cabin does not get cold
Many things can do that like woodchuck mentioned...would have to be investigated...
http://www.applianceaid.com/frig_notcold.html

jeff.
__________________

Appliance Repair Aid
http://www.applianceaid.com/
I support MADD, please don't drink and drive!

jeff1 is offline  
 
Reply With Quote Quick reply to this message
Old 05-20-2012, 10:01 AM  
dglass4321
Junior Member
 
Join Date: May 2012
Posts: 1
Default Same Problem

I have a GE Profile Arctica with the same problem. I have taken apart the freezer section and the fan blades move freely but the fan won't turn on no matter what the control settings are. Since it has been unplugged for several days, there is no frost or ice build up. I have read other posts that talk about the mother board being bad, where is that located and how do I get to it? Thanks for any advice you can offer.

__________________
dglass4321 is offline  
 
Reply With Quote Quick reply to this message
Old 05-21-2012, 11:32 AM  
jeff1
Senior Member
 
jeff1's Avatar
 
Join Date: Mar 2006
Posts: 411
Liked 17 Times on 16 Posts
Likes Given: 1

Default

Hi,

Quote:
GE Profile Arctica
Just names and not a model#...
http://www.applianceaid.com/model.html Some model# helps.

Quote:
I have read other posts that talk about the mother board being bad, where is that located and how do I get to it?
Normally on the back of the refrigerator behind a cover.

jeff


__________________

Appliance Repair Aid
http://www.applianceaid.com/
I support MADD, please don't drink and drive!

jeff1 is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Old Whirlpool Freezer Cold, Fridge Warm dbj15 Refrigerators 2 04-05-2012 02:30 PM
LG LRBC22544ST fridge/freezer combo no longer blowing cold air. umoms Refrigerators 6 11-01-2011 06:37 AM
Help with old homestead Cabin gotfuel Roofing and Siding 2 01-31-2010 11:08 AM
Help with my old Homestead Cabin gotfuel Roofing and Siding 0 01-31-2010 03:42 AM
Main to sub (main lug) panel wiring newdiyer Electrical and Wiring 6 03-30-2007 07:03 PM