DIY Home Improvement, Remodeling & Repair Forum

DIY Home Improvement, Remodeling & Repair Forum (http://www.houserepairtalk.com/forum.php)
-   Plumbing Forum (http://www.houserepairtalk.com/f33/)
-   -   "Giant" hot water tank stoped working (http://www.houserepairtalk.com/f33/giant-hot-water-tank-stoped-working-4110/)

Xilbus 04-29-2008 03:06 PM

"Giant" hot water tank stoped working
 
Good day everyone,

Im stuck and do not know what els to do. Friday night my hot water tank, made by Giant 40gal 1999 stoped working.

We drained the tank, shut off the braker.
We replaced the 2 elements with 2 brand new giant elements the thermostats were replaced with new ones. We tested the wires and 120 is going to both so 240 in total. Hooked back up everything with the giant specifications. We still have no hot water. A hot water tank is just 2 elements +thermostats and a tank so if I replace everything it should work right ? the only thing i didnt replace was the tank.

I wish there was a led or a lcd screen or if there was a humming noise that would tell you that everything is working great. any help would be great

glennjanie 04-29-2008 07:18 PM

Welcome Xilbus:
The water heater should be working, it does take a while for a full tank of cold water to heat up but you should hear a faint boiling noise from the bottom as soon as you turn it on.
I would recommend re-checking all the wires, including the power wire into the top and make sure they are tight and not grounded against something.
Glenn

inspectorD 04-30-2008 05:15 AM

Hmmm
 
Although it's not unheard off....your new elements "could" be bad.
If they still do not work after you check everything, this would be my next step.

Square Eye 04-30-2008 06:48 AM

Are you sure you have it wired correctly?
What color are the wires from the panel and what color are they attached to on the water heater? I have seen them wired wrong and they don't work.
Just a thought.. Worth double checking :)


All times are GMT -6. The time now is 12:40 PM.