DIY Home Improvement, Remodeling & Repair Forum > DIY Home Improvement > Plumbing Forum > "Giant" hot water tank stoped working




Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-29-2008, 03:06 PM  
Xilbus
Junior Member
 
Join Date: Apr 2008
Posts: 3
Default "Giant" hot water tank stoped working

Good day everyone,

Im stuck and do not know what els to do. Friday night my hot water tank, made by Giant 40gal 1999 stoped working.

We drained the tank, shut off the braker.
We replaced the 2 elements with 2 brand new giant elements the thermostats were replaced with new ones. We tested the wires and 120 is going to both so 240 in total. Hooked back up everything with the giant specifications. We still have no hot water. A hot water tank is just 2 elements +thermostats and a tank so if I replace everything it should work right ? the only thing i didnt replace was the tank.

I wish there was a led or a lcd screen or if there was a humming noise that would tell you that everything is working great. any help would be great



__________________
Xilbus is offline  
 
Reply With Quote Quick reply to this message
Old 04-29-2008, 07:18 PM  
glennjanie
Senior Member
 
Join Date: Mar 2006
Posts: 2,992
Liked 2 Times on 2 Posts

Send a message via AIM to glennjanie
Default

Welcome Xilbus:
The water heater should be working, it does take a while for a full tank of cold water to heat up but you should hear a faint boiling noise from the bottom as soon as you turn it on.
I would recommend re-checking all the wires, including the power wire into the top and make sure they are tight and not grounded against something.
Glenn



__________________
glennjanie is offline  
 
Reply With Quote Quick reply to this message
Old 04-30-2008, 05:15 AM  
inspectorD
Housebroken
HRT_MODERATOR.png
 
inspectorD's Avatar
 
Join Date: Dec 2005
Location: Litchfield, CT
Posts: 3,929
Liked 87 Times on 76 Posts
Likes Given: 188

Default Hmmm

Although it's not unheard off....your new elements "could" be bad.
If they still do not work after you check everything, this would be my next step.

__________________

Just My
Made in the

inspectorD is offline  
 
Reply With Quote Quick reply to this message
Old 04-30-2008, 06:48 AM  
Square Eye
Senior Member
 
Square Eye's Avatar
 
Join Date: Jan 2006
Posts: 1,273
Liked 4 Times on 4 Posts

Default

Are you sure you have it wired correctly?
What color are the wires from the panel and what color are they attached to on the water heater? I have seen them wired wrong and they don't work.
Just a thought.. Worth double checking

__________________

[URL="http://www.houserepairtalk.com/announcement.php?f=39&a=6"][size=3]The Ten Commandments of House Repair Talk[/size][/URL]



[URL="http://home.bellsouth.net/p/s/community.dll?ep=16&groupid=289528&ck="]Square Eye's home page[/URL]

Square Eye is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Another pilot lite issue on my hot water tank dp2209 Plumbing Forum 2 12-31-2008 09:51 PM
Tub drains slowly. Toilet water into tub? FearfulOfAsbestos Plumbing Forum 6 06-04-2008 12:45 AM
Fan in hallway timer in garage, stoped working Kevdog98 HVAC 1 03-23-2007 05:29 PM
Air in water tank User Name Plumbing Forum 4 08-07-2006 08:29 PM
Lack of Gas Hot Water rrbhokies Plumbing Forum 5 02-21-2006 09:23 PM