DIY Home Improvement, Remodeling & Repair Forum > Appliances > HVAC > Bad thermocouple in Carrier Furnace???




Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 07-13-2010, 09:37 PM  
weagle
Junior Member
 
Join Date: Jul 2010
Posts: 1
Default Bad thermocouple in Carrier Furnace???

We been having problems with our 20 yrs old Carrier furnace (model# 58GSC065). The furnace has a electric ignition system. After the pilot flame turns on, sometime the heat exchanger burner won't go on, sometime after the heat exchanger burner flames on the blower won't turn on. We suspect it maybe a defective thermocouple issue (not sensing the flame???) but need some expert opinions. Any help will be greatly appreciated. Thanks.



PS We did take out the pilot assyembly and try to clean the thermocouple once before. It got a bit better but then went back to the same problems I described above.



__________________
weagle is offline  
 
Reply With Quote Quick reply to this message
Old 07-14-2010, 03:33 PM  
kok328
Supporting Member
HRT_SUPPORTER.png
 
Join Date: Nov 2007
Location: Grand Blanc, MI
Posts: 2,139
Liked 92 Times on 81 Posts
Likes Given: 60

Default

Try replacing the flame sensor and see if that helps.

__________________
kok328 is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Carrier furnace fan won't switch on Augment HVAC 46 04-09-2010 09:50 PM
Carrier Thermostat viletha HVAC 5 02-07-2010 08:57 PM
Pilot burner replacement - Carrier 58GS150-CB furnace danielr HVAC 0 09-16-2009 09:39 PM
Carrier gas furnace blows cold air tepolt HVAC 5 03-26-2008 03:25 PM
Thermocouple Installation Question gustavovgarcia Plumbing Forum 3 01-16-2006 08:43 PM