DIY Home Improvement, Remodeling & Repair Forum

DIY Home Improvement, Remodeling & Repair Forum (http://www.houserepairtalk.com/forum.php)
-   HVAC (http://www.houserepairtalk.com/f8/)
-   -   Heat Problem (http://www.houserepairtalk.com/f8/heat-problem-16656/)

KenMan 10-17-2013 08:10 AM

Heat Problem
 
In May I bought a condo with electric forced air heat and central air. I was shocked to see my first bill since I had not used either heat or A/C and I knew something was wrong.

Eventually I found 2 of the 3 heater elements had broken and were shorted against the frame causing a constant load. I replaced the elements. The A/C is working fine but yesterday I switched to heat and found the heat and blower would NOT shut off even after reaching set point. Manually switching the Tstat of OFF or A/C seems to work, shutting down the heat and blower.

Bad sequencer? Or maybe bad wiring?

Thanks for any suggestions!

bud16415 10-17-2013 11:49 AM

Far from an expert but it sounds like its shutting down when you kill the “Go” signal by switching the thermostat off and that’s what it should be doing on its own. What kind of thermostat do you have and could it be shot or out of calibration. The old ones I know could be set for one number but not shut off until a much higher actual number.

kok328 10-17-2013 01:26 PM

How long does the fan run for after the T-stat says it's at setpoint?
Could be a limit switch continuing to run the fan until the heat box cools down.

KenMan 10-17-2013 01:28 PM

Hi Bud, Don't know the Tstat age but it's a digital White Rogers so I expect it's fairly new.

bud16415 10-18-2013 05:45 AM

The first thing I would try and rule out is change the battery in the thermostat. I have seen where they start acting up but still have enough power to seem to be working. After you rule that out it seems to me it could be something like kok328 suggests that there is a setting that’s supposed to run the fan for a time after the heat shuts down. You did say the heat and fan are staying on. I’m assuming you have left it run long enough after the set point is hit to rule out its just the fan finishing up. When you switch the thermostat off or switch to the air setting and it shuts the heaters off seems to tell me that the heater end is working ok.

I just replaced my very old mercury switch with a new programmable Honeywell. The instruction book was awful and I had several questions and I reluctantly called the help number. I was pleasantly surprised at the wait time and that they answered all my questions in a few minutes. You might want to try the White Rogers help line also.

The one I bought was under $50 so I didn’t bother trying to trouble shoot the old one.

KenMan 10-18-2013 10:57 AM

OK... embarrassment time. Everything is working fine. When I got home the other day it was COLD inside, windows left open and heat OFF. I switched on the heat and showered. It felt HOT when I came out, blower was still running but place was at set point. I panicked because I had worked on the furnace I felt like maybe something was wrong. I was tired and didn't feel like messing with it. The next day after posting here I switched the heat on and OBSERVED. Yes, the blower runs after reaching set point, which makes sense. Everything has been on AUTO and working fine. Thanks everyone.

bud16415 10-18-2013 11:16 AM

I should start a thread on how many times I have paniced right after I fixed something and thought i screwed up. No problem was a good way to get started here I'm sure you will be back and all is well that ends well.

My friend once installed a window and then foamed it in only to find it wouldnt open. He read the can and it said expanding foam and assumed it was the problem and ripped the whole window out only to find the window came with a screw to keep it shut that was to be removed after install.


All times are GMT -6. The time now is 12:47 PM.