DIY Home Improvement, Remodeling & Repair Forum > Appliances > HVAC > lux air furnace





Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 03-15-2007, 03:59 PM  
duane
Junior Member
 
Join Date: Mar 2007
Posts: 1
Default lux air furnace

induction fan of lux air furnace turns on, ignitor turns on and reaches 2300 degrees, furnace lights, ignitor goes out, furnace goes out - after a few minutes furnace tries to recycle - this repeats as many as five times, furnace goes on lock-out, will not light - must physically turn off power to furnace at switch in basment or thermostat cobntrol, wait a few minutes, turn power back on to furnace, try again - furnace will then run awhile, takes two cycles to run at times and produce heat - what to do?

have cleaned flame sensor and had same checked for cracks, checks out okay - please advise



__________________
duane is offline  
 
Reply With Quote Quick reply to this message
Old 03-17-2007, 09:23 AM  
AlexGB
Junior Member
 
Join Date: Mar 2007
Posts: 6
Default

Sounds strangely familiar.

I had a similar problem with my Luxaire, except once in a while the inducer fan would run and turn off before the ignitor even got a chance to heat. Other times, it would do what you describe.

My furnace guy sent out two different technicians who tried swapping flame sensors, ignitors and other things I don't remember, all to no avail. The final solution was to replace the whole control module (circuit board) for about $220.

Good luck.



__________________
AlexGB is offline  
 
Reply With Quote Quick reply to this message
Old 01-03-2010, 09:36 AM  
john_oconnell
Junior Member
 
Join Date: Jan 2010
Posts: 1
Default same same

Same furnace - same problem - I have a contract with my gas company - they have been out 5 times (3 different technicians) and have no clue - last guy swears the circuit board is OK the problem is the positioning of my thermostat. Just doesn't compute to me.

__________________
john_oconnell is offline  
 
Reply With Quote Quick reply to this message
Old 01-04-2010, 07:06 PM  
baldy
Junior Member
 
Join Date: Jan 2010
Posts: 4
Default

make sure you have a good ground at the igniter remove it carefully use some sand paper where the igniter mounts to for a good ground reinstall and see what happens ....but before you put it back look for cracks in the porcine..

__________________
baldy is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Gas Furnace Maintenance Icehouse HVAC 4 02-17-2012 12:32 PM
Furnace Advice Needed gunit HVAC 3 01-10-2009 03:17 PM
Old Furnace Closet Refurbishing Question rwalker28 HVAC 5 01-05-2009 07:49 AM
Attic Furnace Causing Ice Dam HockeyGuy HVAC 3 01-26-2008 06:18 PM
Attic Furnace remodel101 HVAC 0 02-07-2007 11:20 PM