DIY Home Improvement, Remodeling & Repair Forum > Appliances > HVAC > Not sure how serious a problem I have...




Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-12-2010, 10:49 AM  
msu2000
Junior Member
 
Join Date: Apr 2010
Posts: 1
Default Not sure how serious a problem I have...

Hi all, this is my first time on the board and I'm really hoping to get some experienced people to check out my situation:

I live in an attached condo in Chicago. I'm on the 5th floor and my AC unit is on the roof, which is above the 8th floor. I have been living in the condo for 6 years. In August of '08 (4th year in the unit), I noticed that the air coming out of my vents was no longer cool. I contacted the condo association for their 'recommended contractor' and had him look at the unit. He basically spent about 30 minutes on the roof, looked at the AC, said the valves were the problem 99% of the time, suggested I buy a new unit. I asked him to add freon, which was low, and he did (R-22). I went about 20 months without a problem.

So this past weekend, I turned on my AC, and noticed the air wasn't quite cool. I did some research and had a company come out and look for a freon leak. He checked the unit on the roof for about 30 minutes. He used a sniffer, and did a soap test. Then, he went inside my unit and checked the coil for about 30 min. Afterwards, he said he didn't see any evidence of leaking in either spot and recommended we create a vacuum to test the risers between the roof and my condo.

When we went upstairs to do the vacuum test, he took the caps off the valves (for the first time) and noticed a 'thread-lock' substance. He then started detecting freon leaks and said he was confident that the valves were the problem. He explained that if they were leaking in the past, someone might have put the thread lock on the valves, but that it usually doesn't work, and the correct solution is to replace the entire valves.

He decided to try the vacuum test anyways, and left for a couple of hours. When he got back, he said the pressure in the piping had reduced by quite a bit. I asked if the valves could have caused the pressure to fall (since he was so sure they were the problem before the vacuum test) and he didn't really have a good answer.

Anyways, he told me there was nothing he could do since the risers weren't accessible. He charged me up with R-22, and left.

So, what do I do? Am I wrong in thinking that the valves are part of the closed-loop and they could have been the problem? If the problem really is in the risers, is there truly nothing that can be done? I'm screwed if that's the case!

Please help. I'd really appreciate any advice I get.

Thank you!



__________________
msu2000 is offline  
 
Reply With Quote Quick reply to this message
Old 05-06-2010, 08:59 PM  
slownsteady
Supporting Member
HRT_SUPPORTER.png
 
slownsteady's Avatar
 
Join Date: Jun 2009
Location: Newton, NJ
Posts: 1,006
Liked 139 Times on 120 Posts
Likes Given: 180

Default

Welcome. I'm not sure why no one responded on this sooner. Everyone is usually pretty quick.

My first reaction is; if you get about two years out of a recharge (of R-22) maybe that isn't so bad and you could live with that.

My second thought is that the condo corp. has to have provisions for maintenance of pipes etc. on common property. have you asked them for their advice / policy on the risers?

__________________
slownsteady is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Fly problem cdutoit Pest Control 7 03-24-2010 07:52 PM
Hot tub problem Jim Adkins General Home Improvement Discussion 1 01-10-2008 11:30 PM
AC problem carolifra HVAC 1 09-10-2007 11:45 AM
AC problem TxBuilder HVAC 11 07-15-2006 09:55 PM
AC amp problem cam HVAC 2 03-24-2006 06:22 AM