DIY Home Improvement, Remodeling & Repair Forum

DIY Home Improvement, Remodeling & Repair Forum (http://www.houserepairtalk.com/forum.php)
-   HVAC (http://www.houserepairtalk.com/f8/)
-   -   Tradewinds evap blower slipping on shaft (http://www.houserepairtalk.com/f8/tradewinds-evap-blower-slipping-shaft-14477/)

Dutchman 07-29-2012 09:31 AM

Tradewinds evap blower slipping on shaft
 
I have a Tradewinds TS571 evap cooler new Feb. 2011.

The thing has been banging whenever you turn it on this 2012 season. The unit was out of balance new from the factory to begin with, and it shakes. The squirrel cage doesn't turn in anywhere's near a perfect circle, it wobbles as though it is cocked-eyed.
Worked on it yesterday, got exasperated and quit after 2 1/2 hours. Went back up this morning. I have found that the actual blower wheel (squirrel cage) is slipping on the shaft. I have tried adjusting the set collars to grab hold of it to no avail. When it came new, the blower wheel seemed to be permanently attached to the shaft somehow.

Now, one end of the blower wheel (opposite the pulley side) actually jumps up then turns round like it's seated, then jumps up again, etc., etc. The blower wheel will not seat on the shaft. It seems to me, that if the blower wheel is supposed to be attached to the shaft, that it should be keyed in some way. So far, it looks as though I am going to have to take the whole assembly apart and bring it off the roof.

Any ideas as to the problem and how to fix it?

kok328 07-29-2012 03:44 PM

check to see if the motor is mounted correctly.
almost sounds like you don't have the correct shaft size for squirrel cage.
Install new set screws and use loctite on the threads of the set screws.


All times are GMT -6. The time now is 05:29 AM.