DIY Home Improvement, Remodeling & Repair Forum

DIY Home Improvement, Remodeling & Repair Forum (http://www.houserepairtalk.com/forum.php)
-   HVAC (http://www.houserepairtalk.com/f8/)
-   -   Trane XE60 Problems. (http://www.houserepairtalk.com/f8/trane-xe60-problems-17033/)

Thurge 11-24-2013 09:48 PM

Trane XE60 Problems.
 
Hello,

I'm a fairly recent first time home owner. about 3 days ago my Trane XE60 stopped working. I consider myself pretty handy but I know little about furnaces. So far I know. 1. There isn't an issue with the circuit breaker being tripped. 2. The pilot light is definitely lit. 3. The thermostat looks like it it working properly. I have been searching high and low online for any kind of troubleshooting guide for this furnace. I think it is original to the house (built in 1990) but if I can put off getting a new one I'd like that because (like with so many others) money is a little tight now. Any help will be greatly appreciated especially if it is in plain english and assumes I know NOTHING about furnaces. I do have a multimeter and I'm not afraid to use it. I just need additional info (for instance telling me test the voltage drop across the flux capacitor without making sure I know what you are talking about) like descriptions or photos. I'm really good at following instructions so any kind of guide that you recommend especially one specific to this furnace would be very VERY appreciated.

Thanks.

kok328 11-25-2013 09:07 AM

Besides 'stopped working', do you have any other symptoms/description of what it is or is not doing when it suppose to be turning on?
Is there a red blinking light on the control board and if so, what is the code?
Is there a label on the back of the cover panels that indicates what code your seeing?
Have you cycled the service switch on the side of the unit?


All times are GMT -6. The time now is 10:01 AM.