DIY Home Improvement, Remodeling & Repair Forum

DIY Home Improvement, Remodeling & Repair Forum (http://www.houserepairtalk.com/forum.php)
-   HVAC (http://www.houserepairtalk.com/f8/)
-   -   Trane XE90 - pressure switch error (with pic) (http://www.houserepairtalk.com/f8/trane-xe90-pressure-switch-error-pic-7780/)

FmrLCpl 10-17-2009 03:17 PM

Trane XE90 - pressure switch error (with pic)
 
1 Attachment(s)
Hi,

My Trane XE90, model TUC100C948B7 just threw me a code - Pressure Switch Error (3 flashes) last nite. I opened the panel and took this picture (attached)

questions

1, What is B (a silver round thing), is this a pressure switch?

2, What is A (look like a motor) connects to the PCV pipe lead to outside the house, this part is hot to the touch eventhough the furnace was not running. Since I have 2 Trane XE90, I also open the working one, and the motor in the working unit is cool not as hot.

Thanks

kok328 10-19-2009 04:10 PM

Nice Pic! This is a very common problem at this time of the year.
"A" is your inducer motor and is seized up from not being used all summer.
You should turn the power off, oil the bearings and work the motor by hand to get it to spin again. It might be fried if power was applied but, it didn't spin.
"B" is the pressure switch that tells the system that the inducer motor is doing it's job.
The code you recieved is telling you that the pressure switch didn't "make". This is due to the inducer motor not running. Repair or replace the inducer motor and the pressure switch code should clear itself assuming there are no blockages in the exhaust pipe (i.e.- birds nest, wasp nest, debris, etc...).
Good Luck!

FmrLCpl 10-19-2009 04:55 PM

after I checked all the posts regarding the pressure switch error, I chked the exhaust pipe, cant see any bug at all (the pipe make too many 90 degree turn). At the beginning of the season (early Oct) I turned both the furnaces on to test, they both worked then, several days ago I turned both on again because of the weather, only 1 works. I will try to spin to see if it work, else I will call for service, thanks.

FmrLCpl 10-28-2009 05:12 PM

Quote:

Originally Posted by FmrLCpl (Post 35884)
after I checked all the posts regarding the pressure switch error, I chked the exhaust pipe, cant see any bug at all (the pipe make too many 90 degree turn). At the beginning of the season (early Oct) I turned both the furnaces on to test, they both worked then, several days ago I turned both on again because of the weather, only 1 works. I will try to spin to see if it work, else I will call for service, thanks.

I called for service, my draft induced motor is burned. I checked the web, the WBL0519 is no longer avail. the replacement MOT8640A is around $280. I let the shop do it for around $700, still waiting for the part to come in though.

ciaranobrien 10-26-2011 10:12 AM

Right on the money kok328. Popped my inducer motor out. Spun the motor, applied a little WD40 to the shaft, replaced the motor's, yes two furnaces with the same problem and turned the power back on and lo and befhold both furnaces sparked back up. Many Many thanks and yousaved me a bunch.

FmrLCpl 10-26-2011 10:44 AM

Quote:

Originally Posted by ciaranobrien (Post 62546)
Right on the money kok328. Popped my inducer motor out. Spun the motor, applied a little WD40 to the shaft, replaced the motor's, yes two furnaces with the same problem and turned the power back on and lo and befhold both furnaces sparked back up. Many Many thanks and yousaved me a bunch.

Hi ciaranobrien,

can you tell us where you get the unit from and price?
just in case my other unit decide to go, thanks

cat4ever 11-09-2013 01:21 PM

Same problem here. Inducer fan wasn't turning on, which is a pretty easy check. Just set your thermostat to heat, you should here some clicks, and the inducer blower will hum a little, but won't start.
Took mine off and a poor bird had managed to get in the motor and jam it. When I twirled the shaft he popped right out. Reinstalled and am good to go. Glad I checked here as it saved me some $$$.


All times are GMT -6. The time now is 07:33 PM.