VIEW MY

deepstuff

Gift Premium Subscription To deepstuff

Join Date:

08-03-2008

Last Activity:

06-17-2010 7:49 PM

    ABOUT ME

  • Cars
  • Don

LATEST ACTIVITY

  • Posted in thread: Venting basement washroom??? on 06-16-2010 at 10:21 AM
    Hi,.I'm installing a Saniflow pumping toilet in the basement of my two storey home. I will also
    be connecting a bath tub and vanity sink to this pumping toilet. Can I vent this system through
    a vent c...

  • Posted in thread: exterior steel door leak?? on 10-15-2009 at 11:25 AM
    yes, mine has a magnetic weather strip.

  • Posted in thread: exterior steel door leak?? on 10-14-2009 at 10:46 AM
    Hi, I have and exterior steel door with magnetic seals along the sides and top. On the bottom
    the sill is capped with aluminum with a plastic channel threshold. I have replaced the door
    sweep seal on ...

  • Posted in thread: fan / baseboard heater question on 10-03-2009 at 12:44 PM
    Thats fine Thanks!

  • Posted in thread: fan / baseboard heater question on 10-03-2009 at 06:22 AM
    Hi, Can I put a fan forced wall insert heater on the same thermostat as a 750W baseboard
    heater? I'm looking at putting a Dimplex 1000W fan forced wall insert heater on the same
    thermostat as a 750W b...

  • Posted in thread: Submersible pump issues on 06-16-2009 at 01:43 PM
    I was just told be the local pump shop that if, with the well cap removed, I can hear the pump
    running that the well is low on water. Could this be caused by construction in the area?

  • Posted in thread: Submersible pump issues on 06-15-2009 at 03:28 PM
    With pump running I'm reading 240V on both start and run circuits. Shouldn't the start circuit
    drop out? Or is the capacitor giving me the voltage? Starter is only capactor to start.

  • Posted in thread: Submersible pump issues on 06-15-2009 at 09:02 AM
    I removed the cap from the well and listened to the pump. Most of the time (not all the time)
    when running I can hear a mecahnical chatter almost like a valve clattering. I can also hear
    faint gurglei...

  • Posted in thread: Submersible pump issues on 06-13-2009 at 10:57 AM
    Thanks Glennjanie. I already check the tank precharge and it was good.

  • Posted in thread: Submersible pump issues on 06-12-2009 at 08:43 PM
    I have a federal electric control box (capacitor start) on a submersible pump about 300-feet
    down a drilled well. Its acting as if the well is very low but I find it hard to believe this
    time of year....

0 COMMENTS
POST A COMMENT