DIY Home Improvement, Remodeling & Repair Forum > Appliances > HVAC > Trane XE 90 - normal no call for heat (error code)




Reply
 
Thread Tools Search this Thread Display Modes
Old 10-15-2010, 08:55 AM  
Edd
Junior Member
 
Join Date: Oct 2010
Location: atlanta, ga
Posts: 3
Default Trane XE 90 - normal no call for heat (error code)

Trane XE 90

Red LED on front of unit displaying slow blink pattern (continous 1 blink per second). According to chart this error code is "Normal no call for heat". Also the unit is making a low humming / buzzing sound. When heat is turned on the blinking changes to fast blinking pattern, which according to chart is error code for "Normal call for heat". Otherwise all seems normal. Only noticed blinking light because I was doing routine air filter change and happened to see blinking light. Blower runs when a/c is operating. Heat comes on as normal and blower runs just as it should. Unit turns on and off properly when acitvated by thermostat. I have a service contract with a local company, but want to avoid paying fee for sevice call if possible. What sort of problem may have triggered error code to be displayed? And what do I need to do about it? Thanks.



__________________
Edd is offline  
 
Reply With Quote Quick reply to this message
Old 10-15-2010, 03:53 PM  
kok328
Supporting Member
HRT_SUPPORTER.png
 
Join Date: Nov 2007
Location: Grand Blanc, MI
Posts: 2,230
Liked 116 Times on 101 Posts
Likes Given: 65

Default

If the unit turns on & off properly in both A/C & heat mode then you don't have a problem.
On blink simply says the unit is not calling for heat and the other blink is saying that it is calling for heat and as you've indicated it comes on & off properly.
Am I missing something here?



__________________
kok328 is offline  
 
Reply With Quote Quick reply to this message
Old 10-15-2010, 06:12 PM  
Edd
Junior Member
 
Join Date: Oct 2010
Location: atlanta, ga
Posts: 3
Default

According to the chart on the inside of the safety cover the blinking light signifies an "ERROR CODE". So this leads me to be concerned there is a problem. Also the unit is making a low quiet buzzing sound all the time. The light is not normaly blinking and the unit does not normaly make a buzzing sound at all times. These are my concerns. Does anything need to be fixed, attended to? And can I possibly do it myself?
Thanks.

__________________
Edd is offline  
 
Reply With Quote Quick reply to this message
Old 10-15-2010, 06:39 PM  
paul52446m
Senior Member
 
Join Date: Oct 2010
Location: Houghton Lake, Mi.
Posts: 435
Liked 1 Times on 1 Posts

Default

As KOK328 said you do not have a problem. The buzzing sound is the transformer, and it has always made that noise, a new one would do the same thing. Some buzz loader that others, so relax and take the wife out to supper.
later Paul

__________________
paul52446m is offline  
 
Reply With Quote Quick reply to this message
Old 10-15-2010, 08:54 PM  
Edd
Junior Member
 
Join Date: Oct 2010
Location: atlanta, ga
Posts: 3
Default

So I would agree with you that there is no problem because the unit seems to be working fine to me, but why is the LED light flashing a pattern that indicates an "ERROR CODE"? (If there is no problem/error?) Thanks.

__________________
Edd is offline  
 
Reply With Quote Quick reply to this message
Old 10-15-2010, 10:57 PM  
paul52446m
Senior Member
 
Join Date: Oct 2010
Location: Houghton Lake, Mi.
Posts: 435
Liked 1 Times on 1 Posts

Default

I think you will find out that thats what they call the code system. It is flashing
the code of what the unit is doing. And thats what it is suppose to do. Later Paul



__________________
paul52446m is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Trane XE90 - pressure switch error (with pic) FmrLCpl HVAC 6 11-09-2013 02:21 PM
Trane Heat Pump Assistance outsideperson HVAC 4 02-18-2009 07:31 PM
Trane XE90 Pressure switch code. Truth? showngo2000 HVAC 7 10-13-2008 05:26 PM
central heating error code 31 bonehead HVAC 0 02-06-2008 10:00 PM
Trane XV 1500 Heat Pump Issues !! Craig Christian HVAC 1 07-09-2006 09:14 PM

Newest Threads

LATEST SPONSOR DEALS