DIY Home Improvement, Remodeling & Repair Forum > Appliances > HVAC > Lennox 10ACB60-5p not working

Thread Tools Search this Thread Display Modes
Old 11-05-2011, 08:28 PM  
Junior Member
Join Date: Nov 2011
Posts: 1
Default Lennox 10ACB60-5p not working

I have a Lennox 10ACB60-5P system and when I turn on the heat, I hear a cliking noise from the thermostat but no air is flowing through the ducts. I am not familiar with this system. What should I check for? is it repairable or do I need to replace the system?

Thank you

tgy is offline  
Reply With Quote
Old 11-05-2011, 08:40 PM  
Supporting Member
Join Date: Nov 2007
Location: Grand Blanc, MI
Posts: 2,374
Liked 152 Times on 129 Posts
Likes Given: 71


What should I check for?
Start with shutting off the service switch to the furnace, turn it back on and then try setting to heat mode again.

is it repairable or do I need to replace the system?Can't answer this question until the cause of the problem is found.
Everything is repairable depending on how much money you want to spend and if the repair parts are available.
kok328 is offline  
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Lennox AC does not work Dorene HVAC 3 08-02-2011 02:41 PM
Lennox A/C Problem HardcoreNinja69 HVAC 1 05-29-2010 05:41 AM
Lennox Condensor BWonsch HVAC 1 07-01-2009 10:29 AM
Lennox capacitor Betty HVAC 4 06-02-2008 04:56 PM
1994 lennox fan o0o_ddt_o0o HVAC 1 11-26-2007 09:05 PM

Newest Threads