DIY Home Improvement, Remodeling & Repair Forum > DIY Home Improvement > Tools > Sears power washer




Reply
 
Thread Tools Search this Thread Display Modes
Old 06-10-2013, 06:06 PM  
dtaylor15
Junior Member
 
Join Date: Jun 2013
Posts: 3
Default Sears power washer

I am lucky enough to have a Sears 2700cc power washer model 580-752060, recently, 1 year ago, the power hose attached crossed threaded the outlet of the washer, took it to sears and they replaced, did not use until now, and here is my problem and question. When the unit is running, starts fine, but no pressure, took to neighbor's outside facuet and same results. With hose on, pressing the trigger water will come out, when the unit is running, water stops flowing out of the wand, and the relief valve will blow out HOT water from under the unit. I assume the pump is now bad, has anyone replaced a pump on this unit, Sears is about 89.00 labor and looks like 165.00 + for parts, almost the cost of another unit. Any information input is appreciated. Dennis



__________________
dtaylor15 is offline  
 
Reply With Quote Quick reply to this message
Old 06-10-2013, 06:48 PM  
nealtw
Contractor
 
Join Date: Nov 2010
Location: vancouver, b.c.
Posts: 10,706
Liked 921 Times on 822 Posts
Likes Given: 1585

Default

Don't understand how you got to a bad pump, unless I missed something, Sounds more like a blockage in the wond or a bad pressure release valve. Do you have an inline screen that got plugged when they worked on it.
And welcome to the site.



__________________
nealtw is offline  
oldognewtrick Likes This 
Reply With Quote Quick reply to this message
Old 06-10-2013, 07:17 PM  
dtaylor15
Junior Member
 
Join Date: Jun 2013
Posts: 3
Default thanks for the welcome

I pulled out the screen and it is clean, I can blow air/water thru the wand, and the hose will allow water to pass thru it, until the unit runs, then no water from the wand, not high pressure water or facuet pressure water. With the unit not running, it will squirt water out thru the hose and wand, until the unit runs, then nothing. There is a relief valve on the underside, and after a few minutes, it will dump water, hot water out of the bottom spout. The shaft of the motor into the pump is spinning, so not sure if the issue is the upper piece or the lower piece of the assembly.

__________________
dtaylor15 is offline  
 
Reply With Quote Quick reply to this message
Old 06-10-2013, 07:19 PM  
dtaylor15
Junior Member
 
Join Date: Jun 2013
Posts: 3
Default

Here is the parts layout of the unit:

http://www.searspartsdirect.com/part...0/0247/1505200

__________________
dtaylor15 is offline  
 
Reply With Quote Quick reply to this message
Old 06-10-2013, 07:20 PM  
nealtw
Contractor
 
Join Date: Nov 2010
Location: vancouver, b.c.
Posts: 10,706
Liked 921 Times on 822 Posts
Likes Given: 1585

Default

I don't know enough about these things but it sounds like a problem with work they did.

__________________
nealtw is offline  
 
Reply With Quote Quick reply to this message
Old 06-11-2013, 06:01 AM  
inspectorD
Housebroken
HRT_MODERATOR.png
 
inspectorD's Avatar
 
Join Date: Dec 2005
Location: Litchfield, CT
Posts: 4,093
Liked 125 Times on 105 Posts
Likes Given: 319

Default or

Or , did the unit get frozen at some point over the winter in storage?
May have broken something.

__________________

Just My
Made in the

inspectorD is offline  
 
Reply With Quote Quick reply to this message
Old 06-11-2013, 10:56 AM  
nealtw
Contractor
 
Join Date: Nov 2010
Location: vancouver, b.c.
Posts: 10,706
Liked 921 Times on 822 Posts
Likes Given: 1585

Default

Quote:
Originally Posted by inspectorD View Post
Or , did the unit get frozen at some point over the winter in storage?
May have broken something.
He hasn't used it since the repair.
__________________
nealtw is offline  
 
Reply With Quote Quick reply to this message
Old 07-29-2014, 08:06 PM  
Adirondacker
Junior Member
 
Join Date: Jul 2014
Posts: 1
Default

I also have the same power washer and was power washing my Drive way one day ..left it running while I moved my car ..about a minute ...when I cam back it was shooting water out the side of the pump near what I believed could be a gasket... is it possible or could it have blown a hole in the side of pump... it seems to be a seam and possible a gasket that just blew... ever hear of this ??? ... thanks Frank

__________________
Adirondacker is offline  
 
Reply With Quote Quick reply to this message
Old 07-30-2014, 11:54 AM  
Wuzzat?
Banned
 
Join Date: Jan 2010
Posts: 2,328
Liked 167 Times on 154 Posts
Likes Given: 94

Default

Gasket got old & brittle and blew?
If so you'll need a torque wrench and bolt tightening specs to fix this.

__________________
Wuzzat? is offline  
slownsteady Likes This 
Reply With Quote Quick reply to this message
Old 07-31-2014, 01:57 PM  
elbo
 
Join Date: Nov 2011
Location: , florida
Posts: 78
Liked 21 Times on 21 Posts
Likes Given: 17

Default

disconnect the hose from the pump and see if you get water out of the outlet under pressure, if you do, reconnect the hose and disconnect the wand from the hose and repeat. I f you get water under pressure, then the problem is in the wand. If you don't get pressurized water from the hose then the problem is obviously the hose, which may be
delaminating inside and causing a blockage



__________________
elbo is offline  
nealtw Likes This 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
LG washer ShirleyR General Appliance Discussion 3 07-01-2012 08:10 AM
Recommend an economical power washer thapranksta Tools 6 06-26-2012 06:20 AM
Dish washer billyo General Appliance Discussion 12 01-28-2012 07:12 AM
Extended Warranties from GE (Assurant) and Sears msalwin General Appliance Discussion 0 07-06-2010 08:30 PM
Redwood Siding - sick over power-washer damage newenglandguy General Home Improvement Discussion 1 07-29-2007 10:53 AM

Newest Threads

LATEST SPONSOR DEALS