DIY Home Improvement, Remodeling & Repair Forum > Appliances > HVAC > Problem With Blower Moror




Reply
 
Thread Tools Search this Thread Display Modes
Old 05-22-2014, 08:25 PM  
Jeffh
Junior Member
registry_dropdown_33484_105152
 
Join Date: May 2014
Posts: 6
Default Problem With Blower Moror

I am only getting 15v ac out from my board to the blower motor. Blower motors leads had a resistance in the 7ohm range. Blinking diagnostic was 'idle/waiting' position. when I turned stat up for a call for heat, inducer would turn on, then burner, then high limit and shut down…no blower.
Do any of you knowledgeable people think it would be my board that is faulty?


Jeffh is offline  
 
Reply With Quote
Old 05-22-2014, 09:59 PM  
slownsteady
Supporting Member
HRT_SUPPORTER.png
 
slownsteady's Avatar
registry_dropdown_14946_105154
 
Join Date: Jun 2009
Location: Newton, NJ
Posts: 2,251
Liked 360 Times on 294 Posts
Likes Given: 543

Default

Jeff: start a new thread, you'll get better answers.

(well, I guess you did!)



Last edited by slownsteady; 05-23-2014 at 05:09 PM. Reason: he started a new thread
slownsteady is offline  
 
Reply With Quote
Old 05-23-2014, 03:04 AM  
Wuzzat?
Banned
registry_dropdown_17632_105158
 
Join Date: Jan 2010
Posts: 2,328
Liked 168 Times on 155 Posts
Likes Given: 94

Default

Quote:
Originally Posted by Jeffh View Post
Do any of you knowledgeable people think it would be my board that is faulty?
Yes, but there may be a lot of money riding on your diagnosis. And it may be just a bad $20 relay on your board. Post a schematic and photo of the board.
Wuzzat? is offline  
 
Reply With Quote
Old 05-24-2014, 11:11 AM  
Jeffh
Junior Member
registry_dropdown_33484_105211
 
Join Date: May 2014
Posts: 6
Default

Thanks for your help guys. I figure it is the relay, but I lack the expertise to locate a replacement, detach and solder on a new one. Where is a good online place for relays? I will keep the old one and get a buddy to solder on a new relay, and then I will have a backup board. I replaced the board for $200(canadian) with a newer generation white-rodgers and it works great again.
Jeffh is offline  
 
Reply With Quote
Old 05-24-2014, 11:42 AM  
Wuzzat?
Banned
registry_dropdown_17632_105212
 
Join Date: Jan 2010
Posts: 2,328
Liked 168 Times on 155 Posts
Likes Given: 94

Default

I use Digi-key or Hosfelt.

With a schematic for my board I saw that one pole of a two pole relay was unused so I did a lot of cutting PC tracks and rewiring to use these unused contacts instead of the burnt contacts on the other relay.
It was dumb luck and I checked it many times before applying power.

$200 might be reasonable, I've heard of a kilobuck for some of these touchy boards.

BTW, [less than 30 mV]/[more than 100 mV] across closed relay contacts at rated current means good/bad contacts, respectively.

I tested this benchmark on a blower relay that was right at the 0.1v mark and it worked (but my sample size was only one). The new relay closed contact voltage was virtually zero.

Last edited by Wuzzat?; 05-24-2014 at 11:47 AM.
Wuzzat? is offline  
 
Reply With Quote
Old 05-24-2014, 01:36 PM  
Jeffh
Junior Member
registry_dropdown_33484_105213
 
Join Date: May 2014
Posts: 6
Default

Thanks fir that Wuzzat. Ya I found the part 50a65-843 for only $100, but amazon.com doesn't ship north of the border. I grumbled and paid double, but at least the wife is happy(and cool) again.
Jeffh is offline  
 
Reply With Quote
Old 05-24-2014, 03:16 PM  
Wuzzat?
Banned
registry_dropdown_17632_105214
 
Join Date: Jan 2010
Posts: 2,328
Liked 168 Times on 155 Posts
Likes Given: 94

Default

Yeah, these women. . .they know stuff that men don''t know. And maybe cannot know.


Wuzzat? is offline  
 
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Amana Furnace Blower problem MILL123 HVAC 3 09-26-2012 02:02 PM
Main Line Sewerage Connector Pipe Problem? Sewer Problem? labb_sleuth Plumbing Forum 3 08-09-2012 04:44 AM
blower wire system problem tnbna2012 HVAC 1 07-19-2012 07:22 AM
problem with blower on hydronic heat jlyons HVAC 1 11-10-2008 12:57 PM
AC blower fan does not come on... kurt smith Introductions 9 07-27-2006 09:17 PM

Newest Threads

LATEST SPONSOR DEALS