Connect Honeywell RTH8500 D Thermostat to Trane XE90

Discussion in 'HVAC' started by Fitmiss, Nov 2, 2011.

  1. Nov 2, 2011 #1

    Fitmiss

    Fitmiss

    Fitmiss

    Member

    Joined:
    Nov 2, 2011
    Messages:
    12
    Likes Received:
    0
    I am a new home owner. I have removed the old standard Trane thermostat and replaced it with a Honeywell Programmable Thermostat RTH8500D. I believe I connected it correctly but the inside temperature is not matching the set temperature. I know the heater is on and have seen the pilot lit. I feel heat coming through the vents but my setpoint is 66 and the inside temp only registers 61.

    There were 4 wires; red, white, yellow and green. I connected them to the corresponding colors (conventional heating/ac) on the new thermostat. I'm just wondering if I did something wrong. I don't believe I have a heat pump which is a different connection.

    Question is why inside temp does not match setpoint after several hours even though heater is on? By the way, the filter is new and the red blinking light on the system is constant which I believe indicates the furnace is functioning correctly.
     
  2. Nov 2, 2011 #2

    paul52446m

    paul52446m

    paul52446m

    Well-Known Member

    Joined:
    Oct 7, 2010
    Messages:
    435
    Likes Received:
    1
    don't know that stat, but read your instructions real close. On the back or inside the stat is there any small dip switch? These stats have to work on different systems so there is switches that have to be set for your system.
    I now i had a least 4 Hon. round dial that were off 3 to 4 degrees, so i quit using that stat.
    Anyway check real close and maybe some one will answer you that knows more about the stat you have. Paul
     

Share This Page