GE Profile Problem

Discussion in 'HVAC' started by Toneraider, Dec 8, 2013.

  1. Dec 8, 2013 #1

    Toneraider

    Toneraider

    Toneraider

    Member

    Joined:
    Dec 8, 2013
    Messages:
    5
    Likes Received:
    1
    I have a problem, my GE Profile has hot coils, the fan is turning very slowly (1 rev every 5 seconds). How do I get the fan out (the coil is blocking the white tub from coming out)?
     
  2. Dec 9, 2013 #2

    nealtw

    nealtw

    nealtw

    Contractor retired

    Joined:
    Nov 4, 2010
    Messages:
    23,892
    Likes Received:
    3,117
    Someone moved this to the wrong forum??
     
  3. Dec 9, 2013 #3

    jeff1

    jeff1

    jeff1

    Well-Known Member

    Joined:
    Mar 17, 2006
    Messages:
    465
    Likes Received:
    34
  4. Dec 11, 2013 #4

    Toneraider

    Toneraider

    Toneraider

    Member

    Joined:
    Dec 8, 2013
    Messages:
    5
    Likes Received:
    1
    Jeff,

    It's a PFS22SISBSS. I bought a new motherboard and that fixed the fan problem. Now I can still here the relay clicking but the compressor doesn't come on (though I can here the fans inside are on).

    How do I troubleshoot now? Could it be a starter relay? Is it the compressor?
     
  5. Dec 11, 2013 #5

    jeff1

    jeff1

    jeff1

    Well-Known Member

    Joined:
    Mar 17, 2006
    Messages:
    465
    Likes Received:
    34
  6. Dec 11, 2013 #6

    Toneraider

    Toneraider

    Toneraider

    Member

    Joined:
    Dec 8, 2013
    Messages:
    5
    Likes Received:
    1
    Jeff,

    Thanks, I'll get a reading on the ohms tonight.

    Thanks,
     
  7. Dec 12, 2013 #7

    Toneraider

    Toneraider

    Toneraider

    Member

    Joined:
    Dec 8, 2013
    Messages:
    5
    Likes Received:
    1
    Looks like I'll be ordering a new capacitor and starter relay tomorrow. I'll post my results when they're installed.
     
  8. Dec 12, 2013 #8

    jeff1

    jeff1

    jeff1

    Well-Known Member

    Joined:
    Mar 17, 2006
    Messages:
    465
    Likes Received:
    34
    Please do keep us posted.

    jeff.
     
  9. Dec 13, 2013 #9

    Toneraider

    Toneraider

    Toneraider

    Member

    Joined:
    Dec 8, 2013
    Messages:
    5
    Likes Received:
    1
    Jeff,

    Thank you so much for your help! I replaced motherboard the other night and that made the condenser fan work, just now replaced the starter relay and the compressor is working! Down 3 degrees in about half an hour! Thanks for the help and the diagram!
     
    nealtw likes this.
  10. Dec 13, 2013 #10

    jeff1

    jeff1

    jeff1

    Well-Known Member

    Joined:
    Mar 17, 2006
    Messages:
    465
    Likes Received:
    34
    Thankx for the update :)

    jeff.
     

Share This Page