"Giant" hot water tank stoped working

Discussion in 'Plumbing Forum' started by Xilbus, Apr 29, 2008.

  1. Apr 29, 2008 #1

    Xilbus

    Xilbus

    Xilbus

    New Member

    Joined:
    Apr 29, 2008
    Messages:
    3
    Likes Received:
    0
    Good day everyone,

    Im stuck and do not know what els to do. Friday night my hot water tank, made by Giant 40gal 1999 stoped working.

    We drained the tank, shut off the braker.
    We replaced the 2 elements with 2 brand new giant elements the thermostats were replaced with new ones. We tested the wires and 120 is going to both so 240 in total. Hooked back up everything with the giant specifications. We still have no hot water. A hot water tank is just 2 elements +thermostats and a tank so if I replace everything it should work right ? the only thing i didnt replace was the tank.

    I wish there was a led or a lcd screen or if there was a humming noise that would tell you that everything is working great. any help would be great
     
  2. Apr 30, 2008 #2

    glennjanie

    glennjanie

    glennjanie

    Well-Known Member

    Joined:
    Mar 1, 2006
    Messages:
    2,990
    Likes Received:
    4
    Welcome Xilbus:
    The water heater should be working, it does take a while for a full tank of cold water to heat up but you should hear a faint boiling noise from the bottom as soon as you turn it on.
    I would recommend re-checking all the wires, including the power wire into the top and make sure they are tight and not grounded against something.
    Glenn
     
  3. Apr 30, 2008 #3

    inspectorD

    inspectorD

    inspectorD

    Housebroken Staff Member Admin Moderator

    Joined:
    Dec 17, 2005
    Messages:
    4,502
    Likes Received:
    267
    Although it's not unheard off....your new elements "could" be bad.
    If they still do not work after you check everything, this would be my next step.
     
  4. Apr 30, 2008 #4

    Square Eye

    Square Eye

    Square Eye

    Well-Known Member

    Joined:
    Jan 13, 2006
    Messages:
    1,273
    Likes Received:
    10
    Are you sure you have it wired correctly?
    What color are the wires from the panel and what color are they attached to on the water heater? I have seen them wired wrong and they don't work.
    Just a thought.. Worth double checking :)
     

Share This Page