help on a gas furnace ignition problem

Discussion in 'HVAC' started by zorroo, Nov 19, 2008.

  1. Nov 19, 2008 #1

    zorroo

    zorroo

    zorroo

    New Member

    Joined:
    Nov 19, 2008
    Messages:
    3
    Likes Received:
    0
    Our gas furnace stopped working. The problem is when the thermostat calls for heat, everything looks normal from beginning: the induction fan starts to spin, then the Hot surface ignition comes on. The problem is now there is no flame comes on. It looks to me the gas valve does not open at all. The ignitor comes on for three times and stops trying. I did not see any broken wire. :confused:

    I don't have much experience here, so any suggestion is helpful. Thank you!


    IMG_0113e.jpg

    IMG_0114e.jpg
     
    Last edited: Nov 19, 2008
  2. Nov 19, 2008 #2

    glennjanie

    glennjanie

    glennjanie

    Well-Known Member

    Joined:
    Mar 1, 2006
    Messages:
    2,990
    Likes Received:
    4
    Welcome Zorroo:
    There may be an air velocity switch that will not allow the gas to come on until there is sufficient ventilation. I would check for obstructions in the vent pipe, look at the vent cap and see if it is in good shape.
    Glenn
     
  3. Nov 19, 2008 #3

    zorroo

    zorroo

    zorroo

    New Member

    Joined:
    Nov 19, 2008
    Messages:
    3
    Likes Received:
    0
    Thanks Glenn, did you mean the fume pipe to the roof?


     
  4. Nov 19, 2008 #4

    glennjanie

    glennjanie

    glennjanie

    Well-Known Member

    Joined:
    Mar 1, 2006
    Messages:
    2,990
    Likes Received:
    4
    Yes, that's it.
    Glenn
     
  5. Nov 20, 2008 #5

    zorroo

    zorroo

    zorroo

    New Member

    Joined:
    Nov 19, 2008
    Messages:
    3
    Likes Received:
    0
    Thanks Glenn, I will have a check next week when I when to the house. I will come back to report my findings.
     

Share This Page