High limit problem on Trane XE90

Discussion in 'HVAC' started by Garvey, Dec 18, 2006.

  1. Dec 18, 2006 #1

    Garvey

    Garvey

    Garvey

    New Member

    Joined:
    Dec 18, 2006
    Messages:
    1
    Likes Received:
    0
    Currently have a Trane XE90 60K BTU. It was installed exactly six years ago, and we've owned the house for two years. The furnace worked fine all last winter and then all fall until just before Thanksgiving, when we had a cold and rainy day. It was blowing cold, so I went into the crawl and found that I had an open high limit switch (4 blinks of the LED),

    Since then, this is what's been done:
    High limit switch replaced. Blower speed turned to high. Temp rise reduced
    to 50 degrees (was 58 or so). Sensor adjusted. The only
    remaining thing that wasn't fixed was the return static pressure (is that
    right?) was a little too high--should be .5 and it was more like .75 or .85.
    One guy told me that the return run was too long for its size and that I could shorten it, and that may take care of the problem. I even switched from the quality high-micron filter to a cheaper, more open one to help with that,
    but I could still shorten the run (which I haven't done yet). Should I?

    Well, after all that, it worked fine for two weeks and then the high limit cut it off. Raining that day. Then worked fine for a week (although it's been very warm here and maybe never even kicked on at all). But then it came up again last night (it was humid, but not not crazy or anything). Went into crawl space, pulled the panel off to kill it and restart it, and the burners would kick on for a few seconds and then the high limit would cut it off and run just the blower. So I left the heat off last night, and this AM ran it and it worked great. No high limit problem whatsoever.

    Is it time to throw more money into this unit or just replace it? Will shortening the return run help? Does rain/humidity affect something? That's a theory, albeit a stupid one?

    What I have is an intermittent problem. Never know when it's gonna pop up. I can't rightly say that it's actually too hot and that's why it's tripping. It hasn't rained enough for me to tie it to humidity problems fully, either. Is it the circuit board?

    Thanks!
    Garvey
     
  2. Nov 10, 2011 #2

    thanksagain

    thanksagain

    thanksagain

    Member

    Joined:
    Nov 10, 2011
    Messages:
    6
    Likes Received:
    0
    You mentioned that you reset the switch, mine is blinking 4 timesbut I don't know how to reset the switch
     

Share This Page