Need help with Graco 395 st pro sprayer!

Discussion in 'Painting Forum' started by Robertelicia1, Feb 5, 2017.

Help Support House Repair Talk by donating using the link above.
  1. Feb 5, 2017 #1

    Robertelicia1

    Robertelicia1

    Robertelicia1

    New Member

    Joined:
    Feb 5, 2017
    Messages:
    3
    Likes Received:
    2
    Hi all! I just bought a graco 395 st pro off a guy for fairly cheap. I know pretty much nothing about the sprayer and can't really tell if it even functions properly. I hooked a hose and gun up to it today and tried to run it with water (not paint) on prime and no water would come out of the prime hose. But when i sprayed the gun the water sprayed out normally it seemed. Motor kicked on and pumped.. So basically I'm wondering why i cant get any water to come out of the prime tube? But the sprayer seems to spray properly when i pull the trigger on the gun? Could the prime valve be stuck on spray internally ? Any input would be greatly appreciated!!
     
  2. Feb 5, 2017 #2

    Snoonyb

    Snoonyb

    Snoonyb

    Well-Known Member

    Joined:
    Sep 30, 2006
    Messages:
    2,981
    Likes Received:
    515
  3. Feb 5, 2017 #3

    Robertelicia1

    Robertelicia1

    Robertelicia1

    New Member

    Joined:
    Feb 5, 2017
    Messages:
    3
    Likes Received:
    2
    Thanks. I already had that downloaded and I've read everything possible on the web related to this thing for 2 days and still cant seem to figure it out.
     
  4. Feb 5, 2017 #4

    Snoonyb

    Snoonyb

    Snoonyb

    Well-Known Member

    Joined:
    Sep 30, 2006
    Messages:
    2,981
    Likes Received:
    515
    I've not experienced the particular problem you are, however I do not own, but rent on an extended basis, just being zapped by static electricity.
     
  5. Mar 28, 2017 #5

    Workaholic

    Workaholic

    Workaholic

    Active Member

    Joined:
    Apr 21, 2012
    Messages:
    28
    Likes Received:
    4
    Kind of an old thread but...

    It sounds like your prime valve may be bad. The part ranges from 35-85 $ depending upon how crafty you are at shopping around.
    If it was stuck the other way I would make the assessment that your packings are in need of being repacked and a slight tap of a hammer could un-stick the ball to get the pump through the project.
     
    slownsteady likes this.
  6. Mar 29, 2017 #6

    Robertelicia1

    Robertelicia1

    Robertelicia1

    New Member

    Joined:
    Feb 5, 2017
    Messages:
    3
    Likes Received:
    2
    Thanks for the suggestions guys! It did turn out to be a bad prime valve. Fixed it and it works as it should now. Thanks again for the help!!!
     
    Workaholic and mabloodhound like this.
  7. Mar 30, 2017 #7

    Workaholic

    Workaholic

    Workaholic

    Active Member

    Joined:
    Apr 21, 2012
    Messages:
    28
    Likes Received:
    4
    Awesome I love updates on how stuff turned out. :) Sucks it went out, but it happens. Glad you got it worked out.
     

Share This Page