Trane Furnace Problem

Discussion in 'HVAC' started by coldinwi, Nov 24, 2013.

  1. Nov 24, 2013 #1

    coldinwi

    coldinwi

    coldinwi

    New Member

    Joined:
    Nov 24, 2013
    Messages:
    1
    Likes Received:
    0
    I have a Trane furnace with the three blinking code lights. I think the problem has something to do with he honeywell humidifier attached to it noticed the furnace wasn't working and went downstairs to find everything wet. Shut off the humidifier and now cant get furnace to run. Did everything suggested on other sites, cleaned hoses, pipes everything. When you turn furnace on all I get is a couple clicks no exhaust fan nothing. Any help would be great.
     
  2. Nov 28, 2013 #2

    zagpi

    zagpi

    zagpi

    New Member

    Joined:
    Nov 28, 2013
    Messages:
    2
    Likes Received:
    0
    Could be some sort of "safety" connector that isn't, well, completing the electronic connection. If the door to the blower, on my old gas furnace, isn't on exactly flush then it won't turn on but the ignition won't click either.
     
  3. Nov 28, 2013 #3

    zagpi

    zagpi

    zagpi

    New Member

    Joined:
    Nov 28, 2013
    Messages:
    2
    Likes Received:
    0
    ... with so many sensors and computer chips in everything it could require a "reset". You should be able to do it yourself that doesn't mean it's designed that way. It's like the gas cap on my car, if I screw up the "three clicks" when I close it, I might have to pay my mechanic to reset the "flag" so the engine warning light goes off. Which is stupid of me because I know my brother bought a meter or something that can tell you why the engine light is on, not expensive, and reset him himself.
     

Share This Page