Water softener issue

Discussion in 'Plumbing Forum' started by MIKEINMN, Oct 17, 2012.

  1. Oct 17, 2012 #1

    MIKEINMN

    MIKEINMN

    MIKEINMN

    New Member

    Joined:
    Oct 17, 2012
    Messages:
    1
    Likes Received:
    0
    I have a Kenmore Ultrasoft 150 that is 10 yeras old which recently does not seem to be softening the water. I have tried doing the screen and venturi to make sure they are not plugged. I also took the float assembly out and made sure there is nothing plugged in the screen there. It cycles only when I push the button for it to regenerate. The setting have not changed. The cycling begins and sounds like it is functioning but the water coming out the drain tube is a weak stream. I even took the main head unit off and checked for any blockage and have found nothing. There are no kinks in the drain tube. Salt usage is about the same as before. There is no salt bridge as I went as far as to disconnect the entire unit and flush it out completely and added new salt. Any ideas? Thanks in advance
     
  2. Oct 17, 2012 #2

    Speedbump

    Speedbump

    Speedbump

    Water well etc.

    Joined:
    Apr 17, 2009
    Messages:
    672
    Likes Received:
    72
    Being a Kenmore, it's probably shot. They were never known for their great quality. The mineral in the tank has probably lost most of it's capacity and the timer motor sounds like it finally gave up. You could spend a lot of money trying to fix it (if you could find parts) or you could buy a new one that will be trouble free for several years down the road. In other words, it's not worth fixing.

    You will probably find if you call around for repair, if someone actually does say they will fix it, they will end up trying to sell you a new one.
     
  3. Oct 17, 2012 #3

    Wuzzat?

    Wuzzat?

    Wuzzat?

    Well-Known Member Sponsor

    Joined:
    Jan 20, 2010
    Messages:
    2,471
    Likes Received:
    175
    How much for new Zeolite/resin for your softener and how likely is it to be the problem?

    Here's 8 ea. Nextag prices for a new softener
    800
    460
    600
    550
    550
    1883
    400
    1900
    so half cost between $550 and $800.

    If you want to troubleshoot it, it's both electrical and hydraulic circuits so you probably need a voltmeter, ammeter, GPM meter and PSI meter. And you'll need the maker's spec's.
     
    Last edited: Oct 17, 2012
  4. Oct 31, 2012 #4

    KRMWaterPro

    KRMWaterPro

    KRMWaterPro

    Member

    Joined:
    Jun 21, 2012
    Messages:
    5
    Likes Received:
    1
    If the unit is not automatically backwashing just when you manually backwash then the flowmeter is not functioning properly or the control board is probably bad. The unit counts gallons of water you use and determines backwash frequency by hardness value you enter, size of unit, and the gallons of water used.
     

Share This Page