Weak flame in mobile home gas furnace

Discussion in 'HVAC' started by Doug, Oct 18, 2018.

Help Support House Repair Talk by donating:

  1. Oct 18, 2018 #1

    Doug

    Doug

    Doug

    New Member

    Joined:
    Oct 18, 2018
    Messages:
    3
    Likes Received:
    0
    Location:
    erie, pa
    I have a gas furnace that takes forever to heat up, blows out luke warm air and the blower runs like 45 minutes at a time. Then it shuts off for about 10 seconds and then starts up again. It says weak flame. Any suggestions on what I could check? I already tried changing the thermostat and cleaning everything. Thanks.
     
  2. Oct 19, 2018 #2

    EdInKentucky

    EdInKentucky

    EdInKentucky

    Active Member

    Joined:
    Nov 12, 2016
    Messages:
    28
    Likes Received:
    7
    Might sound crazy, but spiders have a way of getting into mobile home furnace burner orifices, and setting up housekeeping. This blocks or partially blocks the flow of gas too the burner.
     
  3. Oct 19, 2018 #3

    Doug

    Doug

    Doug

    New Member

    Joined:
    Oct 18, 2018
    Messages:
    3
    Likes Received:
    0
    Location:
    erie, pa
    Thank you soooo much. I'll check that out. I appreciate it.
     
  4. Oct 19, 2018 #4

    maxdad118

    maxdad118

    maxdad118

    JOAMOS

    Joined:
    Jan 25, 2017
    Messages:
    275
    Likes Received:
    51
    A furnace is not going to blow ‘hot’ air. It should not shut off until it reaches temperature, you may want to check the ducts to make sure there are no breaks or tears causing heat loss?
     
  5. Oct 19, 2018 #5

    Doug

    Doug

    Doug

    New Member

    Joined:
    Oct 18, 2018
    Messages:
    3
    Likes Received:
    0
    Location:
    erie, pa
    Thank you.
     

Share This Page