DIY Home Improvement, Remodeling & Repair Forum > General Discussion > Introductions > Water Softener Problems




Reply
 
Thread Tools Search this Thread Display Modes
Old 03-03-2007, 10:11 AM  
amaz
Junior Member
 
Join Date: Mar 2007
Posts: 2
Default Water Softener Problems

I noticed that our water softener system, the EcoWater Systems ESD 2502 R30 has water spilling over the top of the resin tank sleeve. When I took of the top cover I noticed that there was water between the resin tank and the sleeve filled to the top.

I also noticed that there was some water in the brine tank next to the brinewell.

Help! What would cause the sleeve to fill up with water?



__________________
amaz is offline  
 
Reply With Quote Quick reply to this message
Old 03-03-2007, 10:57 AM  
glennjanie
Senior Member
 
Join Date: Mar 2006
Posts: 2,990
Liked 2 Times on 2 Posts

Send a message via AIM to glennjanie
Default

Welcome Amaz:
There should be a float switch to shut the water off before it floods over into the sleeve. You can look inside and feel for the switch or look at the wiring diagram to locate it. Apperantly the switch is sticking and allowing over fill.
Glenn



__________________
glennjanie is offline  
 
Reply With Quote Quick reply to this message
Old 03-04-2007, 08:29 AM  
amaz
Junior Member
 
Join Date: Mar 2007
Posts: 2
Default

Glenn,

Thanks for the quick repsonse. Unfortunately there is no float switch. I looked everywhere, in the wiring diagram and in the unit itself, but no luck. Any other suggestions.

Thanks for your time,
Andrew

__________________
amaz is offline  
 
Reply With Quote Quick reply to this message
Old 03-04-2007, 08:39 AM  
CraigFL
Senior Member
 
Join Date: Mar 2006
Posts: 409
Default

I'm assuming you have a dual tank system. I think glenn was talking about when it over fills the brine tank. It sounds like you are saying that it is leaking from the top of the resin tank. Since the resin tank is under water pressure at all times you need to try to find if the leak is coming from the tank top seal or maybe from the switchover valve.

__________________
CraigFL is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Tub drains slowly. Toilet water into tub? FearfulOfAsbestos Plumbing Forum 6 06-04-2008 01:45 AM
Erratic hot water supply with Takaji tankless B.Thomas Plumbing Forum 2 05-24-2008 09:58 PM
Water softener problem CraigFL Plumbing Forum 3 10-16-2006 11:04 PM
Lack of Gas Hot Water rrbhokies Plumbing Forum 5 02-21-2006 10:23 PM
Water heater problems newowner General Appliance Discussion 2 11-16-2005 12:40 PM

Newest Threads

LATEST SPONSOR DEALS