DIY Home Improvement, Remodeling & Repair Forum > Appliances > HVAC > Trane XE90




Reply
 
Thread Tools Search this Thread Display Modes
Old 06-04-2009, 05:53 PM  
TheGunMan
Junior Member
 
Join Date: Jun 2009
Posts: 1
Default Trane XE90

I have a Trane XE 90 that was installed in Feb 2001. Yesterday, it stopped producing heat. This morning I checked my breaker box and saw that the furnace breaker had tripped. I reset the breaker and checked the diagnostic codes. The LED flashed 5 times, then flashed 9 times repeatedly. I replaced the Igniter (code 9), but the furnace does not come on and the LED still flashes "9", after initially flashing code 5. The blower does come on (I think it is the blower that circulates air thru the ducts. Any suggestions? It still gets cold at night in northern Ohio. Thanks.



__________________
TheGunMan is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Trane XE90 LED Troubleshooting Codes furmanator HVAC 11 11-10-2011 09:27 PM
Trane XE90 Propane flashing lights Espritman HVAC 1 12-31-2008 10:44 PM
Trane XE90 Malfunctioning kappaman HVAC 2 12-16-2008 05:22 PM
Trane XE90 Won't stay lit nifaron HVAC 2 11-16-2008 03:09 PM
Trane xe90 flue move homerepairguy HVAC 4 05-10-2007 12:38 PM

Newest Threads

LATEST SPONSOR DEALS