DIY Home Improvement, Remodeling & Repair Forum > Appliances > HVAC > Lennox Condensor




Reply
 
Thread Tools Search this Thread Display Modes
Old 07-01-2009, 09:03 AM  
BWonsch
Junior Member
 
Join Date: Jul 2009
Posts: 1
Default Lennox Condensor

I am an electrician by trade.Our Lennox A/C stopped working.I found very corroded wires on the condensor connections.(one off)Cleaned everything up.Windings showed 1.1 and 2.5 ohms.After starting up again the unit still just hums.Getting 220 volts to unit.Relay comes in no problem.My question is if the unit was working fine and a wire fell off,what is left to check.A repairman changed one cap and it made no difference.He said the other cap didn't matter.Any ideas???



__________________
BWonsch is offline  
 
Reply With Quote Quick reply to this message
Old 07-01-2009, 11:29 AM  
glennjanie
Senior Member
 
Join Date: Mar 2006
Posts: 2,990
Liked 2 Times on 2 Posts

Send a message via AIM to glennjanie
Default

Welcome BWonsch:
Try pushing the contactor in with your screwdriver and see if the compressor runs; then look at the low-voltage wiring which is supposed to pull the contactor in.
Glenn

__________________
glennjanie is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Lennox A/C condensor fan motor GWS HVAC 23 07-18-2012 12:33 PM
Lennox Fan Motor needs replaced? gogoguy HVAC 2 05-24-2009 08:40 AM
Lennox capacitor Betty HVAC 4 06-02-2008 05:56 PM
Lennox vs American Standard ctopher HVAC 5 05-15-2008 06:09 AM
1994 lennox fan o0o_ddt_o0o HVAC 1 11-26-2007 09:05 PM

Newest Threads

LATEST SPONSOR DEALS