DIY Home Improvement, Remodeling & Repair Forum > DIY Home Improvement > General Home Improvement Discussion > furnace problem

Thread Tools Search this Thread Display Modes
Old 10-22-2009, 10:54 PM  
Junior Member
Join Date: Oct 2009
Posts: 1
Default furnace problem

I have a 8 year old furnace. It is Amana 80 SV
After My furnace is flood with water , the central air still works fine , but when I turn on the heat , it is not working , no flame ....

The led trouble code is 3 blinks = "Pressure switch stuck "

is Pressure switch is bad ? do I need to replace it ? I take out the end of the hose and blow it , I hear click from pressure switch , the hose is not clogged .
Please advice me . Thanks.

letony is offline  
Reply With Quote
Old 10-24-2009, 11:22 AM  
Jimm Two
Junior Member
Join Date: Oct 2009
Posts: 3
Default pressure switch error

check this thread in may help; follow the peoples tips they worked for me
Trane XE 90 pressure switch. good luck
Jimm Two is offline  
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter DIY Home Repair Forum Replies Last Post
Thermostat or furnace problem? dakuda HVAC 8 01-02-2010 04:05 PM
Gas furnace igntion problem uilleann13 HVAC 1 01-15-2009 05:25 PM
York Stellar Furnace problem clayjthom HVAC 7 12-28-2008 03:58 PM
help on a gas furnace ignition problem zorroo HVAC 4 11-19-2008 09:36 PM
Gas Furnace problem mekanic Introductions 3 04-14-2006 06:08 PM

Newest Threads