Emerson Disposal

Discussion in 'General Appliance Discussion' started by Jiggersing, Jul 19, 2008.

  1. Jul 19, 2008 #1

    Jiggersing

    Jiggersing

    Jiggersing

    New Member

    Joined:
    Jul 19, 2008
    Messages:
    1
    Likes Received:
    0
    I can manually move it with a little wrench or from inside -- can spin each impeller and rotate the whole gizmo, BUT when I turn on the switch, there is an electrical hum but no functioning. It is an Emerson E100, maybe 15 years old?
     
  2. Jul 20, 2008 #2

    jeff1

    jeff1

    jeff1

    Well-Known Member

    Joined:
    Mar 17, 2006
    Messages:
    465
    Likes Received:
    34
    Hi,

    If not jammed up but the motor is hummmmmming only....sounds like a bad motor = shopping time.

    jeff.
     
  3. Jul 21, 2008 #3

    Charlie

    Charlie

    Charlie

    Active Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    If you are sure that everything is moving then it is probably a bad motor.

    On the plus side though with a 15 years old disposal you/somebody got their moneys worth :)
     
  4. Jul 22, 2008 #4

    majakdragon

    majakdragon

    majakdragon

    Well-Known Member

    Joined:
    Sep 16, 2006
    Messages:
    165
    Likes Received:
    0
    Sounds like a motor problem. After 15 years, the blades are probably getting dull anyways and a new unit is in order. Emerson is the manufacturer of Insinkerator disposals so changing it out should not be a problem.
     

Share This Page