Heil Propane Unit

Discussion in 'HVAC' started by tndave, Nov 7, 2012.

  1. Nov 7, 2012 #1

    tndave

    tndave

    tndave

    Member

    Joined:
    Mar 7, 2011
    Messages:
    23
    Likes Received:
    0
    I Thank Ya’ll Very Much for the previous help!!!

    For Reference See:

    http://www.houserepairtalk.com/f8/heil-propane-unit-10905/#post54753


    New season…new problem…It has been working just fine and just now…not so much. It got cold in here, so I went to see what’s happening & first time the inducer came on, ignighter came on & she fired up, main fan came on & after about 30 seconds the inducer/lighter/flame died & main fan kept running. Now when I try it nothing happens for a while & the main fan comes on & just keeps blowing cold air. Propane tank says it’s at 10%, was hoping to have it filled soon…short on $$$...any help would be Greatly Appreciated!!!

    Thanks!!
    DD
     
  2. Nov 7, 2012 #2

    tndave

    tndave

    tndave

    Member

    Joined:
    Mar 7, 2011
    Messages:
    23
    Likes Received:
    0
    I just tried again & inducer came on, igniter started to glow & both quit & main fan came on. Short time later tried it again, nothing happened for a while & main fan came on. So it seems the longer you wait to make something happen more things happen…
     
  3. Nov 7, 2012 #3

    tndave

    tndave

    tndave

    Member

    Joined:
    Mar 7, 2011
    Messages:
    23
    Likes Received:
    0
    Gas stove works fine & wall heater works fine.
     
  4. Nov 8, 2012 #4

    tndave

    tndave

    tndave

    Member

    Joined:
    Mar 7, 2011
    Messages:
    23
    Likes Received:
    0
    After being turned off for 9 hours I tried it again & absolutely nothing happens for a while and the main (house) fan comes on. Everything worked fine until this morning right before I made the first post. I have to go to work in about an hour, but I can check posts from my phone. It’s supposed to get down to 35 here tonight. Wife & kids will be using wall heater & blankets while I’m at work (third shift).

    Thanks!!
    DD
     
  5. Nov 8, 2012 #5

    tndave

    tndave

    tndave

    Member

    Joined:
    Mar 7, 2011
    Messages:
    23
    Likes Received:
    0
    I just read my old post. I guess I'm having amnesia ill check the relay when I get home in the morning.
     
    Last edited: Nov 8, 2012
  6. Nov 8, 2012 #6

    tndave

    tndave

    tndave

    Member

    Joined:
    Mar 7, 2011
    Messages:
    23
    Likes Received:
    0
    Ok, got it going again...same thing as last year. Cleaned up the connection & it's working.
     
  7. Nov 9, 2012 #7

    nealtw

    nealtw

    nealtw

    Contractor retired

    Joined:
    Nov 4, 2010
    Messages:
    23,892
    Likes Received:
    3,117
    Glad we could help;)
     

Share This Page