no cool air

Discussion in 'HVAC' started by lartomar2002, May 20, 2007.

  1. May 20, 2007 #1

    lartomar2002

    lartomar2002

    lartomar2002

    Member

    Joined:
    Feb 25, 2007
    Messages:
    8
    Likes Received:
    0
    i have a package unit and occassionally the coil freezes up and the blower stops working. after i defrost the coils the blower starts up and i get cold air. any suggestions.:eek:
     
  2. May 21, 2007 #2

    glennjanie

    glennjanie

    glennjanie

    Well-Known Member

    Joined:
    Mar 1, 2006
    Messages:
    2,990
    Likes Received:
    4
    Yes, the reason it freezes up is lack of air circulation and it closes off the coil, completely stopping the air flow.
    The condenser coil needs to be cleaned thoroughly and then check the hi and low pressure in the unit. Many A/C techs will just "add a little gas" rather than actually checking out the problem and taking proper action. Indeed, you can add some refrigerant to a dirty coil and start it cooling again.... until it gets more dirt on it. These guys never check the hi side pressure because you can get frostbite taking the gauge hose off the high side.... unless you know how to do it. I have found systems with the hi side at 450 psig or more.
    The refrigerant doesn't have a chance to vaporize completely in the evaporator coil and, in some cases, will actually bring liquid refrigerant back to the compressor. Bye bye comressor; it can't pump liquid.
    Rule number 1 is clean first, gas last it would make units last years longer. Its just easier to say, "it just needed a little gas". Folks, it doesn't burn up, wear out or shrink; if it needs gas you have a leak somewhere.
    Glenn
     

Share This Page